DEAD PC?

Hi, I have a PC that I built myself early last year - everything has worked generally fine up until today when the PC refused to power up.... The Mobo light is on but nothing happens when I hit the Power Button...
Tried so far - swapping pwr button for reset button - no change, reset cmos - no change, removed all none essential components - cleared cmos = no change. All remaining connections are seated perfectly so left stumped... Also I do not have any spares now to try other components :(

Sabretooth p67 mobo
I7 cpu
HD 6870
2 X 4GB ADATA Memory
Thermaltake TR2 800W PSU
In a Thermaltake Dokker case

I know the Sabretooth p67's are buggy boards and the lower powered psu's are a bit poop too.
Just need some fresh ideas on what to try next - i'm not a pc literate person either so please be gentle! :)
2 answers Last reply
More about dead
  1. Hi, Do the CPU and the case fans spin when powering up?
    If not, there's a test for power supplies:
    http://www.youtube.com/watch?v=5FWXgQSokF4
  2. Hi bud, the case and everything else did nothing - no response at all to the power button. just finished shorting the PSU and it's dead - no fan spin... Thought it would be that but the mobo light was on so had a few doubts, reckon the relay has gone - damn annoying as the psu cost me a blooming fortune at the time and expected a bit more life time than a year! won't be buying Thermaltake again!!!
    Cheers for your input! Happy Christmas and may the beers be with you! :)
Ask a new question

Read More

Homebuilt Systems