Sign in with
Sign up | Sign in
Your question

Purchased new computer, starts up but no display...

Last response: in Systems
Share
December 13, 2012 7:23:15 PM

Hi Guys

Recently bought this http://www.amazon.co.uk/OCHW-COMPUTER-Multimedia-BULLDO...

It arrives, gets unpacked and powered up, everything seems to be functioning the fans are on but the computer will not display on my TV, done some searching on the internet, removed the motherboard battery to reset the BIOS however nothing has changed. At the moment the computer has no OS because nothing is displayed on the screen. We using a HDMI cable from the computer to the TV, we've tried 3 different TV's and an SVGA(?) cable which is used on the computer i am on now.

Not really sure what to do, i am not tech savy at all, from what i can tell everything is plugged in right, however there is a wire on the motherboard that is not plugged into anything, i dont know if this can cause it or not. Not sure what to do next, return it? or is there something simple to fix this?

If you guys need more information tell me and ill post more, i do not know what i am doing with computers so if you have any fixes could you please explain them in steps that are easy to follow for a novice.

Thanks in advance
December 13, 2012 8:17:03 PM

Are you able to send it back? You might just want to do that, and then maybe build one on your own, as you can get a much better computer than this. The GPU in the one you just bought is not very strong.

Are there graphics on the motherboard?
!