Sign in with
Sign up | Sign in
Your question

GTX 670 Black Screen

Tags:
  • Nvidia
  • Gtx
  • Gigabyte
  • Graphics
Last response: in Graphics & Displays
Share
October 25, 2012 3:51:47 PM

I just bought and installed my gigabyte windforce gtx 670 and am experiencing random black screens. I've read similar posts on the issue but none quite like this so im not sure how to fix it. All my games begin to run just fine, but after about 5 or 10 minutes, the screen will randomly turn black. If I turn my monitor off and back on again - I regain the picture but will continue to experience the black screen. GW2 wouldn't even run, could hear the background music but no picture - uninstalled OC guru and works like charm...aside from the random black screen. Also, this card takes a 6 and 8 pin power connector, as I did not have another 8 pin, I used the adapter that it came with, and plugged it into 2 4-pin power connectors that I just plugged into my PSU. Any ideas?

System Specs:

Intel i7-2600k
Gigabyte Z68XP-UD4
Gskill 8gb sniper series 1600
1tb western digital caviar black hdd
Antec TP-750W PSU
Gigabyte Windforce GTX 670 OC

More about : gtx 670 black screen

October 25, 2012 3:54:29 PM

Sounds like Windows is simply telling your monitor to go to sleep. Check your monitor sleep settings in CP.
m
0
l
October 25, 2012 4:00:14 PM

Doubtful, I have the screen saver/sleep set to 'never'
m
0
l
Related resources
October 25, 2012 4:08:20 PM

Well now its going black on my main desktop page - no idea whats causing it. all drivers are up to date. But if i turn the monitor off and back on again its just fine until it happens again.
m
0
l
March 3, 2013 1:39:00 AM

I am having the same problem. When it kicks to the screen where is asks you if it's okay for a program to make changes to the computer. That's when it regularly does it. Also, when I start some games. It's very weird.
m
0
l
March 3, 2013 1:53:55 PM

I ended up returning my card. Same problem with the new one but its no where near as bad and doesn't happen half as often. I also tried different cables and different monitors, same deal. BUT, the issues subsides some when I use the DVI vs the HDMI. I'm not using the speakers on my monitor so im just fine using my DVI, in fact, the picture looks and responds a little better in game. In either event, I never found a solution to the problem.
m
0
l
a c 173 Î Nvidia
March 3, 2013 1:59:18 PM

Have you tried changing the settings in the Nv control panel?
m
0
l
March 3, 2013 3:21:46 PM

I have a GTS 450 that will never send anything but a black screen out the HDMI port no matter what I do. Its sending a signal because if I unplug the cable I get different results, its just sending a black screen. I worked around the problem by using one of the DVI outputs instead, with a passive DVI to HDMI adapter and that works fine. There seem to be a lot of bugs in these cards.
m
0
l
!