Graphic card not working

When I use to boot my pc with my ATI 5450 hd ddr3 1gb, the system boots and even it starts successfully but only I can hear the sound of windows start up... I cannot se anything....means there is no display from the begining to the start,,,,, :(
But when I plug my monitor cable to onboard,,,, the display comes...I removed my graphic card and put it in my frnds pc,,, it worked fine.....but with me it doesnt..........it worked for me for 5 months but now the problem arises and I also cheked the bios for the priority of graphic card and it is in proper order but why automatically it happen to me now.... :'(.... Plz help....Hurry....I want to play NFS Most Wanted 2012...plz help
5 answers Last reply
More about graphic card working
  1. Can you post some additional info about your system. Motherboard at least.

    If it worked for the last 5 months and the card still works in your friend's PC I'd check his card in your PC to rule out Mobo problems.
  2. my motherboard is Asus M2N68-AM Plus and my frnd doesnt have any garfic card :(
  3. Hmmm, that's unfortunate. It's an easy way to check the motherboard as cause. The motherboard also doesn't have a 2nd slot you can try.

    Standard approach: Update all drivers, BIOS etc.

    Did you do anything significant around the time this happened? Or anything you don't think is significant? Install something, drop the case, something like that? If you are the type to let the computer sleep at night instead of turning it off "around the time this happened" can stretch back a fair bit.

    Also, in your friend's system, did it merely work? Or did you get full functionality? Did you check whether it just produced vision or did you go in to catalyst center/gpu-z to check whether it was recognized as PCIe 2.1x16. Alternatively did you get the FPS you would expect of this card in a game you tried?
  4. hrshraj462 said:
    When I use to boot my pc with my ATI 5450 hd ddr3 1gb, the system boots and even it starts successfully but only I can hear the sound of windows start up... I cannot se anything....means there is no display from the begining to the start,,,,, :(
    But when I plug my monitor cable to onboard,,,, the display comes...I removed my graphic card and put it in my frnds pc,,, it worked fine.....but with me it doesnt..........it worked for me for 5 months but now the problem arises and I also cheked the bios for the priority of graphic card and it is in proper order but why automatically it happen to me now.... :'(.... Plz help....Hurry....I want to play NFS Most Wanted 2012...plz help

    you should check your RAM also...detach ram stick...clean off from the dust..clean RAM slot also..reseat them and see how it ends....
  5. Hey....now I found that the graphic card automatically start working....When Yesterday I turned me pc on with my monitor cable in my motherboard's port,,,,the monitor doesn't show anything but the computer started.....and after that I put my monitor cable in my grafic card port and that amazed me :)....the vision is back...I was very happy yesterday as my grafic card automatically started working and I was able to play Most Wanted.... :) :)
    But When I turned My Pc today...the same old problem rised.....when I turned my pc on...it started but I'm not able to see anything through my monitor....:( ;(
    And again when I switched my monitor cable from my grafic card to my motherboard's port...the display came.... Now I m not understanding why this happening to me.... Plz help
Ask a new question

Read More

Radeon Graphics Cards Graphics Displays