Sign in with
Sign up | Sign in
Your question
Solved

Ati catalyst control center ( Need old download)

Last response: in Graphics & Displays
Share
October 27, 2012 10:15:13 PM

I need the old download with out xfire cause it messes up my card and fps

Best solution

a b U Graphics card
October 28, 2012 12:11:08 AM

You have a 3870x2 mobility, you should check the website of the company that made your laptop for the best drivers for it, and not the generic ATi ones.
Share
Related resources
October 28, 2012 12:12:19 AM

trapper said:
You have a 3870x2 mobility, you should check the website of the company that made your laptop for the best drivers for it, and not the generic ATi ones.



trying that now, i didnt have this problem when i used vista
m
0
l
October 28, 2012 12:13:56 AM

Best answer selected by bayeasy.
m
0
l
a b U Graphics card
October 28, 2012 12:45:13 AM

Which GPU are you using? As far as I know xfire has been a part of catalyst drivers since 2005.
m
0
l
a b U Graphics card
October 28, 2012 12:55:21 AM

What GPU do you have? And unless you have two cards or more and enable Crossfire it will not use any Crossfire tech. At least on my Sapphire HD 6950 and Sapphire HD 7950 the newest drivers have always been the best on my systems.
m
0
l
!