Sign in with
Sign up | Sign in
Your question

Weird GPU problem?

Last response: in Graphics & Displays
Share
October 28, 2012 2:23:09 PM

I recently bought a new machine with a AMD Radeon HD 6670 in it. It played games fine for a week. I recently changed power supply to Corsair 650W because the stock was horrible. I tried to play a game yesterday and after about 30 secs to a minute the screen goes black or it freezes then it unfreezes but from then on the FPS of the game drop to extremely slow rates until I restart my computer then the cycle happens all over again.


AMD FX-4100 Quad Core 3.6ghz
8GB DDR3
500GB HITACHI
AMD HD RADEON 6670
CORSAIR TX650W

More about : weird gpu problem

October 28, 2012 2:40:05 PM

First run GPU-Z and then play the game. Before it crash shut the game down and in GPU-Z sensor tab look for maximum voltage the GPU used during game. I am not a geek but I think it may be a problem of power. Because once I overclocked my GPU and didn't raise voltage and I faced freezing and PC hang.
October 28, 2012 2:44:06 PM

Funny you say that because these problems didnt happen until I tried OC my card for about 15 mins then I switched back to the normal mode. The next day I turn my PC on the problems started. Trying this now though.
Related resources
Can't find your answer ? Ask !
October 28, 2012 2:55:48 PM

Ok so I ran GPU-Z and during the game it stayed at 0.9V most of the time sometimes jumping to 1.05V, the HIGHEST it got during the game.
October 29, 2012 5:12:05 AM

Seb117 said:
Ok so I ran GPU-Z and during the game it stayed at 0.9V most of the time sometimes jumping to 1.05V, the HIGHEST it got during the game.


May be overclocking did something to it. There may be two reasons, either bad power supply or it overclocks itself during gaming, note its core clock and memory clock usages in GPU-Z while you were playing game,were they overclocked during game? Try to run it in other PC. Or if you can increase voltage try to do that also.
!