Sign in with
Sign up | Sign in
Your question

pioneer cld-3070 problem

Last response: in Home Theatre Legacy
Share
Anonymous
May 5, 2004 2:45:24 AM

Archived from groups: alt.video.laserdisc (More info?)

The problem with it is the power keeps shutting off on me. Sometimes it shutts
off right in the middle of the draw going in or out. I have to unplug and plug
it back in so I can get the LD discs out. Any thoughts what the problem could
be? Thanks in advance
Anonymous
May 5, 2004 2:07:48 PM

Archived from groups: alt.video.laserdisc (More info?)

deslardesslok@aol.com (DeslarDesslok) wrote in message news:<20040504184524.21846.00000761@mb-m15.aol.com>...
> The problem with it is the power keeps shutting off on me. Sometimes it shutts
> off right in the middle of the draw going in or out. I have to unplug and plug
> it back in so I can get the LD discs out. Any thoughts what the problem could
> be? Thanks in advance


My thought is that the LD player is telling you it needs to be
replaced. This machine is starting to get pretty old. I may just be
a pessimist when it comes to older electronics, though.

Todd
Anonymous
May 5, 2004 2:45:10 PM

Archived from groups: alt.video.laserdisc (More info?)

deslardesslok@aol.com (DeslarDesslok) wrote...
> The problem with it is the power keeps shutting off on me. Sometimes it shutts
> off right in the middle of the draw going in or out. I have to unplug and plug
> it back in so I can get the LD discs out. Any thoughts what the problem could
> be? Thanks in advance

Send it to Kurtis and have him take a look at it. Luckily, this model
goes for only $100 or less on eBay, so it is easily replaceable if it
is going to need a major repair.

HTH,

-Junior
Anonymous
May 5, 2004 2:52:53 PM

Archived from groups: alt.video.laserdisc (More info?)

"DeslarDesslok" <deslardesslok@aol.com> wrote in message
news:20040504184524.21846.00000761@mb-m15.aol.com...
> The problem with it is the power keeps shutting off on me. Sometimes it
shutts
> off right in the middle of the draw going in or out. I have to unplug and
plug
> it back in so I can get the LD discs out. Any thoughts what the problem
could
> be? Thanks in advance

On this model the problem is "usually" caused by a faulty contact at the
ribbon cable that runs from the front panel circuit board to the main board.
The front panel needs to be removed and reseating the cable will most likely
correct the failure...
!