Sign in with
Sign up | Sign in
Your question

Monitor no signal, keyboard and mouse no light

Last response: in Systems
Share
December 17, 2012 10:58:32 AM

I cleaned my CPU case and the GPU and after connecting it back and turning it on the monitor displays no signal and the mouse and keyboard's light doesn't turn on but the CPU and GPU fan is running but no beeps. The dvd drive can also be opened. I tried removing the GPU and connecting the monitor to the the motherboard but it still doesn't work so the GPU is not the problem. What could be the problem?
a b B Homebuilt system
December 17, 2012 11:34:05 AM

Double and triple check ALL power connectors on every componet. If that doesn't fix things there is a link under my sig for trouble shooting just that type of problem. Follow it carefully and don't skip steps. Hopefully it will be something simple.
m
0
l
December 17, 2012 11:56:54 AM

I only removed the GPU when I cleaned it and I already checked and tightened all connectors. I also removed the RAM and the motheboard beeps.
m
0
l
Related resources
a b B Homebuilt system
December 17, 2012 1:26:46 PM

Have you tried the steps in the link yet? Sometimes just taking it all apart and doing a rebuild will solve the problem.
m
0
l
December 17, 2012 9:55:30 PM

Tried taking it all apart including cpu heatsink and reseating all parts but nothing happened.
m
0
l
December 17, 2012 11:33:16 PM

I finally fixed it, the problem was the RAM wasn't inserted properly.
m
0
l
a b B Homebuilt system
December 18, 2012 1:54:28 AM

Glad I could help
m
0
l
!