First boot, screen doesn't turn on

Ok so yesterday I bought all new parts for an entirely new system I am building for my parents. I put everything together, and checked all the connections and standoffs twice, and when I turned in on, the screen did not turn on. I tried with 4 different screens. Any ideas?

Specs:

i5-2500k
16gb corsair vengeance
tx 650 watt psu
intel dp67bg mobo
xfx 6450
ocz vertex 3 120gb ssd
wd caviar black 500gb hdd
corsair 400d case
h70 water cooling
25 answers Last reply
More about first boot screen doesn turn
  1. Does everything else come on and do you hear any beeps at post (at least one)? If so, have you tried different cables for the monitor connections such as VGA and DVI. I have seen that this particular board does not utilitze DVI-A cables so make sure it is a true digital cable if your using DVI

    DVI-A connector
  2. Everything else turns on, the fans, lights, water pump, hard drives, disk drive, and the LED skull on the motherboard, but there are no POST beeps from the built in speaker. I've tried both VGA and DVI
  3. You could try the GPU in a different machine to rule that out. Also, try to boot with just one stick of RAM in and in different slots. Do you have the 8 pin CPU power cable plugged in to the motherboard?
  4. 8pin is plugged in, tried moving the memory around to different slots, and tried the GPU in both pci slots
  5. Hi, If you start the board with ony CPU and CPU fan installed, do you get the error beeps signaling no RAMs?
    If not, then I would reinstall the CPU and check the socket for bent pins.
  6. There aren't any beeps at all
  7. If the CPU fan does spin when starting the board and the case speaker is properly connected and does work, then it's either a CPU or a board issue.
    Try reinstalling the CPU and checking the CPU socket for bent pins.
  8. You're plugging the monitor into the GPU instead of the motherboard, right? Or have you tried both the motherboard and GPU video outputs? One or the other should work out of the box, and there are usually options in the BIOS to enable/disable one or the other.
  9. The motherboard model doesn't have integrated graphics.

    Try this, unplug the power cord from the PSU. Reset the CMOS jumper by shorting it out with a screwdriver. Then, take the battery out of the motherboard and press the power button on the case. This will do a hard reset and drain the capacitors. Put the battery back in (with no RAM) and see if you get any beeps. Double check the PC speaker and make sure the you have it connected the right way (there should be a little triangle on the connecter which is ground).
  10. It has an integrated speaker. I will try the hard reset though.
  11. Hard reset didn't do anything, still no beeps
  12. Baffled. Wouldn't rule out a bad BIOS chip. This is what makes all POST operations happen.
  13. try posting the mb outside the case to rule out the i/o shield or the mb grounding out. check the back side of the mb make sure if there a heat sink plate if it metal it not touching anything.
  14. The heatsink plate is plastic....do I have to replace this?
  15. your ram is dead try booting with other ram

    I had this exact same problem once, so i just went out got some new ram(you can rma it or get it replaced)and vwuala
  16. That's not good. There should be a copper plate on the bottom of the heat sink and, usually, a thin layer of pre-applied thermal paste. I think this "plastic" is covering the bottom, protecting the thermal paste.
  17. Oh sorry cball...i thought you were talking about the bracket on the back of the motherboard. Nevermind. No, the thermal paste is touching the processor.
  18. plastic plate on back is good.if not they have to ship a rubber spacer with it that a lot of people forget to use.
    looking online the mb has to have bios 1569 to post. i would email intel see if they can tell by the date code of the mb what bios is on the board. the last thing to check...bent pins under the cpu.
  19. Just checked cpu, no bent pins.
  20. [:panicmaster85:2] hey just wanted to let you know its your ram so if you want to keep trouble shooting problems that wont help then go ahead but if you really want to fix it then try and get another set of ram you can put in your machine to test it or just try the other busses or slots
  21. The ram is fine. I just tested it in my other computer and it works fine.
  22. Try the GPU in your machine. If it boots, looks like you might have to RMA the board and/or the CPU. I don't know what else to do.
  23. it has to be the board then, try the other slots on the motherboard you have with the ram, but yeah if that does not work you will hvae to rma the motherboard

    P.S. sorry for kinda being a douche before I was pissed when i wrote that :P
  24. Yea it is definitely the board. I just tested the GPU, and the CPU in my other computer and both of them work. I'll see if I can just get it exchanged at the TigerDirect store where I bought it...RMA would take too long. Its supposed to be a christmas gift -.-
  25. lol ok well good luck! :D
Ask a new question

Read More

Homebuilt Systems