Sign in with
Sign up | Sign in
Your question

Cannot boot windows if USB port is in use

Last response: in Windows 7
Share
February 28, 2012 10:57:42 PM

I have a weird problem.... I couldn't boot windows anymore, i spent a lot of time looking for the cause of the problem when i finally realised that windows will boot only if USB ports are NOT in use. This means that i have to unplug my keyboard, mouse, and all other USB devices BEFORE starting up my computer. Or else, it will get stuck as soon as the windows logo starts to appear during the loading screen.

Anyone know how to fix this weird problem ?

More about : boot windows usb port

a b $ Windows 7
February 28, 2012 11:24:07 PM

Go into the BIOS and set the boot priority to not include USB. IE, set first boot to CD, second to HD, then 3rd to USB. Sounds like that is what's hanging it up...
m
0
l
February 29, 2012 1:37:49 AM

^+1 Definitively that is the problem, and i would recomend not using USB as a boot priority at all, just set it * none* for third boot device.
m
0
l
Related resources
February 29, 2012 6:06:19 AM

Ok i just went to my BIOS, indeed first boot priority was set to USB.

I removed everything from the boot priority list except my system HDD... Everything else is set to disabled... But problem still persist and i can't boot if i don't unplug all usb devices
m
0
l
February 29, 2012 9:28:51 AM

You could try restoring your bios to default factory settings.
m
0
l
March 7, 2012 7:15:09 AM

Just tryed resetting to defaults, didnt help, same problem is still here
m
0
l
a b $ Windows 7
March 7, 2012 2:36:34 PM

Can you take a pic of your BIOS screens, especially the boot priority and any others that have anything pertaining to it? Or at least tell us what mobo and BIOS version you have?
m
0
l
March 7, 2012 2:59:10 PM

My motherboard is MSI z68a-gd65... not ure which bios version, i never upgraded it (bought motherboard around 2 months ago, at first was working fine then suddently started bugging). I'll try to take a picture of my BIOS soon, but like i said i desactivated everything in the boot priority, the only thing left is my SSD and its on the top of the list..
m
0
l
a b $ Windows 7
March 7, 2012 8:21:39 PM

Do you have Click BIOS installed (the Windows BIOS control program)?
m
0
l
March 12, 2012 5:17:34 PM

No i don't know what is click bios

Ok here's a follow up:

i found a "solution"... I now use a 7-port USB hub and plug everything in it. This is the only way i can get my computer to boot without unplugging all USB periphericals

However, 90% of the time the computer will hang at boot and act very weird.

As soon as i boot the computer, it just hangs there with a flashing white bar " _ "
After a few minutes it will finally display something :
"Marvell 88se91xx adapter bios version 1.0.0.1027"

Then it hangs there again.... Then it display "press CTRL+N to access BIOS" which is very weird because i never ever had to use CTRL+N to use BIOS... It was always the traditional delete button since i bought this motherboard...
m
0
l
a b $ Windows 7
March 12, 2012 8:37:16 PM

As long as your hard drive and optical are on the 'regular' SATA plugs, you can disable the Marvell controller in your BIOS to help speed it up. The Marvell is the ports you'd use if you were setting up a RAID array.
m
0
l
December 14, 2013 10:52:43 AM

Hi, have you solved this problem? I know this is an old post, but I'm having the exactly same issue. And its frustrating that cannot find solutions anywhere.
Please help!
m
0
l
!