Sign in with
Sign up | Sign in
Your question

PC Won't power off when shut down.

Tags:
  • Homebuilt
  • Shutdown
  • Jumper
  • Systems
Last response: in Systems
Share
December 19, 2012 12:05:27 PM

Okay, my PC has been doing this thing where it won't turn off after I've shut down windows. It's done this before, and I fixed it by moving the jumpers on the motherboard, because that resets the CMOS battery or something along those lines?

Well, it's being doing it occasionally for 2 months, and I left it alone because it was only quite rare that it wouldn't shut down. My system is over clocked slightly (2500k @4.0 ghz, asus P8P67). So, I figured I just needed to move the jumpers again, but since it wasn't a big problem, I left it alone.

Now just over a week ago, I installed a second hard drive in my system, a 2TB WD green, for storage. And since then, my pc has done the not turning off thing every time. I tried flashing the CMOS battery today, (moving the jumpers), only this time it hasn't fixed the problem?

Any thoughts?

More about : power shut

a b B Homebuilt system
December 19, 2012 12:14:00 PM

download and run ccleaner to clean your registry from errors. that might fix it
m
0
l
December 19, 2012 12:44:01 PM

I've done that, hasn't had any affect on powering off sadly.
m
0
l
Related resources
a b B Homebuilt system
December 19, 2012 12:53:16 PM

What exactly happens when you shutdown. Does it just stay on the desktop? Do you get a screen saying that you can now power down the machine? Do you get any errors or windows trying to force programs to stop?
m
0
l
December 19, 2012 12:54:09 PM

sounds like a windows update apply error. check your logs in event viewer and windows update histroy.
m
0
l
December 19, 2012 12:54:23 PM

Have you tried updating your BIOS?
m
0
l
December 19, 2012 1:06:08 PM

My Bios is up to date, or it was in August. Had no issues in that department that I know of. When it happened before, it seemed to be down to the fact that I'd been trying to find a stable over-clock, and obviously, had had unstable ones along the way. Flashing the CMOS fixed it last time, but since then I have fiddled with my overclock, and so, I was expecting to have to flash it again at some point. But like I said, since installing the second HDD, it has started doing the not powering off everytime. :/ 


When I press shut down, it shuts down as normal (splash screen comes on saying 'Windows is now shutting down' or something like that, then the screen turns off, because there's no longer a signal being sent to the monitor, and the monitor standby light comes on. Then it just stays on, the light on the front stays on and and hear the fans spinning, but it doesn't power down. No programs having to be forced to close that I'm aware of, and no errors either that I can see.

I'll check the event viewer logs.
m
0
l
a b B Homebuilt system
December 19, 2012 1:16:16 PM

What kind of PSU do you have? List your full specs just in case.
m
0
l
a b B Homebuilt system
December 19, 2012 1:18:34 PM

Have you updated you chipset drivers? If no update, try reinstalling them. Make sure that that you are not using any RAID controllers if you don't plan on using a RAID array.
m
0
l
December 19, 2012 1:19:42 PM

Specs:

Zalman Z9 plus case.
i5-2500k
P8P67 motherboard
2 x 4GB Corsair Vegeance 1600mhz C8 RAM.
MSI 6850 Cyclone
Samsung Blu ray player (dont know its number of my head).
1TB WD Blue (OS installed on this).
2TB WD Green (New storage drive)
Antec 620W HCG (non mondular).
Win 7 64-bit.
m
0
l
a b B Homebuilt system
December 19, 2012 1:38:39 PM

You can also check the Event Viewer to see if any errors occur during shutdown. Start -> right-click Computer -> Manage. In the left pane go to Event Viewer. Expand the Event Viewer menu (little triangle) and go to Windows Log -> System. Scroll through the events and find the last time you tried to shutdown and see if there are any errors.
m
0
l
December 19, 2012 1:47:56 PM

@thequn. Apparently I had a Microsoft Security essentials definition update fail on 16th November, but that was the only thing that seemed amiss. And I think that got 'overwritten' if you like by another update the next day.

As for event viewer, that's not something I know much about, and it seems very confusing. The is something called 'WMI' that gives an error (10) every so often in the windows logs>application, but at the same time there are a lot more 'WMI' entries that don't give errors. :/ 

@cball1311 - I haven't updated them recently, apparently I'm on version 9.2.0.1015, and there is a 9.2.0.1021 update that I already have downloaded. Should I update it? I'm not very knowledgeable on drivers, do I have to uninstall the existing one first? I've only really done drivers on a fresh system you see.

m
0
l
December 19, 2012 1:48:07 PM

Just my two cents, but I'd guess you have a jumper wrong on your motherboard causing it not to shutdown.
m
0
l
December 19, 2012 1:49:09 PM

I don't know much about Raid controllers, I'm certain I'm not using any. Don't you need some kind of PCI card with a controller on it to do RAID?
m
0
l
a b B Homebuilt system
December 19, 2012 1:53:42 PM

Windows has built in software raid you can use, and a lot of mid-range MOBO's have built in hardware raid controllers. You would have had to specifically set up your drives in RAID either way, hardware or software.
m
0
l
a b B Homebuilt system
December 19, 2012 1:56:20 PM

I looked up WMI, and looks like it is a windows process that is necessary for the OS. You could have had an issue with some kind of Windows update that screwed the WMI stuff up, causing your shut-down error. If I get a chance I will look into it a little more for you and see if there is a common solution, but worst case scenario I would try a repair install or non-destructive full install.
m
0
l
December 19, 2012 2:01:55 PM

Well, pretty sure it that case I'm not doing anything to do with Raid.

A quick check shows WMI has been giving errors pretty much since I installed my OS, back in February. So, perhaps its not likely it has suddenly begun causing the power off issue, but then again, maybe it could have. :/ 

And checking in the Win update history, the MSE definitions is the only failed update as far as I can see.
m
0
l
December 19, 2012 2:07:22 PM

mmilner1 said:
Just my two cents, but I'd guess you have a jumper wrong on your motherboard causing it not to shutdown.



How many jumpers would my motherboard have? I checked in my manual, it only seems have one 'jumper' listed on the diagram, with three pins, and this controls the CMOS RTC RAM.
m
0
l
a b B Homebuilt system
December 19, 2012 2:24:37 PM

Yes, that would likely be the only jumper on the board. If you remember specifically what day it started check your event viewer and find out what happened that day, and post back.
m
0
l
a b B Homebuilt system
December 19, 2012 2:41:23 PM

There should be two sources in the event viewer that show a shutdown. Kernal-Power and Kernal-General stating the there was a shutdown transistion started and a shutdown of the os at some time, respectively. If both of these go without an error, it is most likely a hardware issue.

m
0
l
December 19, 2012 2:43:52 PM

Well, it had been doing it on and off for a while, but, I mean that might have been once every 2 weeks overall, so I wasn't concerned. But, I installed my new HDD on the 11/12, and since then it seemed to do the no shut down everyday. Looking on that day, I can't see anything amiss, except a distributedCOM error (10010), but I'm not really sure what that is or does. This was before, not after, the installation of the new HDD.
m
0
l
December 19, 2012 3:02:32 PM

cball1311 said:
There should be two sources in the event viewer that show a shutdown. Kernal-Power and Kernal-General stating the there was a shutdown transistion started and a shutdown of the os at some time, respectively. If both of these go without an error, it is most likely a hardware issue.



They're both present without errors. What types of hardware could it be? SATA cable? My new HDD is on a separate line of power connectors to my boot HDD and BlueRay drive. Could that affect anything?


m
0
l
a b B Homebuilt system
December 19, 2012 3:12:16 PM

No, shouldn't be a problem with SATA connections or power. I even looked at your Mobo manual for power management. There is one thing that you could check there and that is in APM. Make sure that the On power loss options (1st one) is set to power off. Might be irrelevant since you said this was happening intermittently.

Ok. Two more things to try.

First, go into Device Manager from the Control Panel and go to IEEE1394 Bus Controllers. For every instance (should be 1), right click on the device, go to Properties. Then in the power managment tab, select Allow computer to turn off to save power. If it doesn't work, just uncheck after reboot. I have read that these can cause shutdown problems.

Second, you said you were getting WMI errors. Try to disable that in services. Start -> type services in search bar -> find Windows Management instrumentation in the list -> right-click to properties -> Where is says Automatic, change to Disable.
m
0
l
December 19, 2012 4:01:17 PM

I checked in the bios, and it is set to power off. I tried the other two things (individually), and there was no change to the powering off.

I really appreciate everyone's help btw. I'm going to be away from my pc for the rest of today, but any other suggestions or ideas would be much appreciated.

All the best,
Dan.
m
0
l
December 20, 2012 12:00:06 PM

Hmm. Odd. But last night after I came home (I had left my pc asleep), and I had a little browse online before turning it off, he actually shut down without any fuss. Of course, this morning he's back to his old tricks again.

I'm thinking I might do a fresh install of windows actually. Good to get a clean start now and again. And since I have my storage hard drive, backing things up is a lot faster than it used to be.

Ofc if anyone has any other thoughts before I go ahead with it, please let me know.

Dan,
m
0
l
a b B Homebuilt system
December 20, 2012 1:13:14 PM

You could compare Event Viewer events with last night and this mornings if you want to delve into that, and see if there are any differences (other than sleep mode, of course) but a fresh install would most likely fix it. It is a shame that many have to do this as a solution. Oh well, it's Windows, and I have had to do this several times on my machine.
m
0
l
December 20, 2012 5:40:35 PM

I'm not too fussed. It's good to have a fresh start. This will be my first reinstall since I assembled my pc & did all the drivers. So, I'm sure reinstalling may get rid of some 'gremlins'.

Thanks for the help though!
m
0
l
a b B Homebuilt system
December 20, 2012 5:54:05 PM

Cool deal. Happy fresh install :D 
m
0
l
December 25, 2012 4:58:39 PM

Okay. I did a fresh install a few days ago.
I did it Saturday, the powering down issue has been fixed. Only, now I'm having issues with BSOD's. I've had two today.

(I was having these just on the last few days before I re-installed windows too), but I was certain I knew how I had caused them (trying to update my chipset driver I believe).
I'm getting the IRQL_NOT_LESS_OR_EQUAL code. I've had a lot of trouble with BSOD's in the past, but eventually fixed them, I found it was down to not having the correct USB drivers.


The tragic thing is, from day one Jan 2012, I had all the wrong motherboard drivers installed on my pc. (Asus P8P67 as opposed to Asus P8P67 REV 3.1) - because I got them from the website rather than the disk, and the REV 3.1 page at the time wasn't showing in the P67 chipset list for motherboards. So, for months I had BSOD's, and I finally got them fixed this august (USB3 drivers from the disk).
I realised the drivers were all wrong when trying to update the motherboard bios in august...and wondered why it wouldn't take the bios update. I also realised in august that since day one, my system had been overclocked (thanks to the TPU switch).


But. Fresh install. Correct drivers from the correct asus motherboard page (Lan, USB, Audio, Chipset, Intel MEI) dunno if I need the MEI though. There's no bluetooth driver on the asus website...but luckily one on the disk (I noticed the 'unknown device' - bluetooth adapter in device manager after BSOD number 1. Thought it might fix it. Now I'm a bit puzzled though since I had another.

But yeah, a pretty disastrous experience with my first home built PC. So much went wrong (and on the plus side, so much wiser as a result), but now I'm genuinely stumped. I'm going to finish off some windows updates, and see if that makes a difference. I know I'll need to make a new thread, either here or perhaps on windowssevenforums (they helped me with bsod's before), but for now I'm just venting steam!

Dan,

m
0
l
!