Motherboard doesn't recognize two SATA hard drives


i5 3570k
Gigabyte GA z77-DS3H
OCZ ZT 550 fully modular power supply
Western Digital Caviar Black 1 TB
Samsung 840 Series 64 GB SSD.

I have the SATA power cables plugged into the power supply and into the hard drives. Data cables are plugged into SATA 0,1, and 3 (ssd, hdd, optical), but the BIOS only recognizes the Optical drive as connected. The other slots are "empty"

Things I've tried:
-both drives work and are recognized in another computer
-tried different ports on the power supply.
-tried a different OCZ modular power supply
-swapped out motherboard (for same model)

I don't know what to do.
6 answers Last reply Best Answer
More about motherboard doesn recognize sata hard drives
  1. Did you try taking the sata plug out of the optical drive and plugging the sata drive(s) into it to see if they are recognized? You probably need to install the sata III drivers to get them to work. Do the OS install with the hdd in the sata II connector, then install the drivers from the motherboard disc. After you get that done you can switch out the sata drives into sata 0 & 1, which are probably the white sata 6GB/s.

    Or just plug them into any blue sata II connector and they should work.
  2. Best answer
    Try updating your BIOS. Simple thing, but I can't tell you how many times this has worked.

    Edit: On startup, try getting into your motherboard's boot manager. Sometimes you are able to see things here that don't show up on the bios.
  3. make sure your not plugging the hard drive..ssd into the third party sata ports. i done it..most times these ports are turned off in the bios.
  4. Thanks a lot for the replies, guys. Nothing has worked so far. The only ports on the board are controlled by the intel controller. Whatever port the optical drive is in, that it recognizes. The boot manager also doesn't show the drives.

    Tried putting the HDD into the SATA II ports...not recognized.

    Updated the BIOS from F7 to F9...drives not recognized.

    Different SATA cables...not recognized.

    I don't understand what's going on.

    EDIT: Nevermind. I hit "load defaults" for the new BIOS and restarted and I see my drives...? Well, I'm not exactly sure what happened, but I guess this is closed.
  5. Best answer selected by mortonww.
  6. Maybe in your BIOS / SETUP there is option for controller work: "AHCI | IDE | RAID". When you hitted "load by defaults" you also switched this one to "old" values. Read on google about "AHCI vs IDE", and try to pick best settings for you. AHCI should be better if it will work in your case.
Ask a new question

Read More

Homebuilt SATA Hard Drives Power Systems