Sign in with
Sign up | Sign in
Your question

Weird Driver Issue

Tags:
  • Radeon
  • Graphics
Last response: in Graphics & Displays
Share
November 2, 2012 5:45:49 PM

Hello,

I have an odd problem that I may have difficulty describing well since I'm not at my computer, and how I describe the problem is pretty much from memory.

I'm running a Dell Studio 8100 with a stock HD 5670 and Windows 7 64-bit. A couple weeks ago I decided to do a fresh OS install due to some weird maleware infection and the reinstallation went smoothly. I then went to AMD's site and downloaded the latest driver (the same version I was using before the reinstall with no issues), installed it, and got a BSOD (something about a memory fault or whatever). So, I uninstalled that driver and installed the 2010 version from the Dell website. Worked like a champ. Then I went back to AMD's site, redownloaded the previous driver, installed with same results. I then rolled back to the previous 2010 version and it's working perfectly.

Any ideas? It's almost like the new driver is no longer compatible with my card, but it worked fine before the reinstallation of Windows.

Thanks for any help!

More about : weird driver issue

November 2, 2012 6:54:30 PM

download all the windows updates?
m
0
l
November 2, 2012 7:05:01 PM

did you make sure you installed your mb chipset drivers first?? if there missing the pci bus can act funny.
m
0
l
November 5, 2012 11:28:54 AM

I did not do that. They're installed now, and right now there aren't any errors showing in the device manager. Would that be something I would need to redo? Uninstall both then install the chipset drivers first?
m
0
l
November 5, 2012 11:33:52 AM

Yes, Windows has been fully updated. Everything's working fine in terms of stability and performance with the driver I'm using, so this isn't a huge deal. I would like to use the newer version of Catalyst to access the overclocking options though.
m
0
l
!