New Mobo BIOS and Video Card AXTU crashing

Just got my gtx 660 today. Installed the 306.97 drivers and updated my mobo BIOS to 2.40(ASRock z77 extreme4) with a 3570k. I was having a lot of problems I didnt understand but I found out I needed to update my system clock and it fixed the core of my problems.

My current problem is that ASRock Extreme Tuning Utility will not load. It crashed everytime I try to boot it and gives no error message.

Also, I am getting some tearing in BF3. I think it may have gone away but initially it was pretty bad. I was at around 45 fps with Adaptive Vsync. I turned on Lucid Virtu MVP and it didn't help. I didnt notice it much after I got to playing more.

Edit: Also, I can't get MSI afterburner On Screen Display to work either.
2 answers Last reply
More about mobo bios video card axtu crashing
  1. why did you flash your mobo bios in the first place? is there problem with previous bios? about the screen tearing problem try enabled v sync and not adaptive one. if the tearing still happen revert back to previous driver. i heard some people get screen tearing with the latest whql but there are no such problem on my 460 yet
  2. eric4277 said:
    Just got my gtx 660 today. Installed the 306.97 drivers and updated my mobo BIOS to 2.40(ASRock z77 extreme4) with a 3570k. I was having a lot of problems I didnt understand but I found out I needed to update my system clock and it fixed the core of my problems.

    My current problem is that ASRock Extreme Tuning Utility will not load. It crashed everytime I try to boot it and gives no error message.

    Also, I am getting some tearing in BF3. I think it may have gone away but initially it was pretty bad. I was at around 45 fps with Adaptive Vsync. I turned on Lucid Virtu MVP and it didn't help. I didnt notice it much after I got to playing more.

    Edit: Also, I can't get MSI afterburner On Screen Display to work either.


    Im having the same damn problem but I never updated my Extreme 4 Bios. It used to work but not it load up then a bunch errors appear from AXTU then it shows balnk blue window with UI layout. Its AXTU not your BIOS

    EDIT: NEVER TOUCH LUCID ON EXTREME 4 OR YOUR PROBLEMS WILL WORSEN. Stay away from it please I dont want you to have more problems. It killed peoples Extreme 4s
Ask a new question

Read More

Graphics Cards BIOS Graphics