Sign in with
Sign up | Sign in
Your question
Solved

Bad bios Flash HD 6870

Last response: in Graphics & Displays
Share
November 3, 2012 1:00:40 PM

Motherboard: Intel DH55TC

Processor: Intel core i3 540

Power Supply: Corsair CMPSU-600CXV2UK 600 Watts PSU

GPU: AMD Radeon 6870 IceqX 1 GB



I saved bios of 6870 with the help of GPU-Z and copied it to my desktop. Then I edited voltage with the help of RBE .I kept original bios unmodified. I made a bootable USB and flashed my 6870 with this edited bios and it worked fine. I played lots of game with this for one week. But after one week I flashed my GPU with a bios downloaded from TPU. This new downloaded bios is of same model Radeon HD 6870. ATIFlash warned me not to flash as checksum of both bioses were different but I flashed it forcefully. Now I have black screen. Then I removed this GPU and put DVI cable in onboard video port and in motherboard's bios I set it to boot from onboard video port. Then I inserted bootable USB with original bios on it and restarted PC and choose to boot from USB buttttttt now it does not boot from USB, monitor says no signal. How would I restore original bios to GPU???

people say on forums that if you have bad bios flash then reflash it with the original one using on board video. I do not have another PCIe slot but I have a PCI slot and a PCI VGA.

Please help friends please :cry: 

More about : bad bios flash 6870

Best solution

November 3, 2012 1:53:48 PM

oh
Share
November 3, 2012 2:37:05 PM

Now sometimes it booted from USB and when I launched ATIFlash -i command it says "adapter not found" . Now is there something I can do?
m
0
l
Related resources
November 4, 2012 4:40:28 AM

Where are those geeky people of Tomshardware???????? Now I really need help. Such a huge site it is but not a single good reply when it is really serious matter. :( 
m
0
l
a c 109 U Graphics card
November 4, 2012 5:10:45 AM

Boot off of onboard.

Select second card.

Flash second card with original BIOS.
m
0
l
November 4, 2012 5:34:27 AM

amuffin said:
Boot off of onboard.

Select second card.

Flash second card with original BIOS.



here is what I did-

1. Made a bootable USB.

2. Put atiflash and original bios of my GPU on it.

3. Restarted the PC and from motherboard's bios I selected motherboard's video adapter.

4. Pluged the bootable USB and started the PC and selected to boot from USB

5. PC booted from USB and when I type atiflash -i it showed me adapter not found. I repeated this process many times but same result.


I have my original bios but ATIFlash is not recognizing my dead GPU when I boot from bootable USB. If it would recognize I would restore my original bios again.

why atiflash is not recognizing my GPU and what should I do to make it recognize my GPU???
m
0
l
November 15, 2012 4:28:26 AM

Best answer selected by nona2011.
m
0
l
!