Sign in with
Sign up | Sign in
Your question

HELP!!! Installing AMD display driver

Last response: in Graphics & Displays
Share
November 3, 2012 4:57:46 PM

I am about this break my computer because i can't do this SIMPLE SIMPLE task!!! *i am not retarded*

my brother bought an DELL XPS 8500 desktop and it comes with a dedicated HD 7570 card, but he doesn't want to use it....their i get to have it *yes finally a dedicated card for my own computer, i know im poor*

so i went along and downloaded the newest driver from AMD DRIVER .COM version 12.10 here

http://support.amd.com/us/gpudownload/windows/Pages/rad...

after installation i can not open "catalyst control center" it's NOT in "right click" on desktop screen.

the ATI TECHNOLOGIES folder is always empty,

i have tried un-installing and reinstalling over and over and over again. and always the same issues.


i have tried many methods of completely remove all trace of AMD stuff and re-installing.



with that 12.10 driver package i downloaded. i went under "custom" to see what actually installs

i see only 3 things

1. AMD Catalyst Install Manager
2. AMD APP SDK Runtime
3. HDMI/DP Audio Driver.


no Catalyst Control Center on that list.


help please!!!! this is so simple and i can't even do it....so frustrating!!!
a b U Graphics card
November 3, 2012 5:29:23 PM

kensic said:
I am about this break my computer because i can't do this SIMPLE SIMPLE task!!! *i am not retarded*

my brother bought an DELL XPS 8500 desktop and it comes with a dedicated HD 7570 card, but he doesn't want to use it....their i get to have it *yes finally a dedicated card for my own computer, i know im poor*

so i went along and downloaded the newest driver from AMD DRIVER .COM version 12.10 here

http://support.amd.com/us/gpudownload/windows/Pages/rad...

after installation i can not open "catalyst control center" it's NOT in "right click" on desktop screen.

the ATI TECHNOLOGIES folder is always empty,

i have tried un-installing and reinstalling over and over and over again. and always the same issues.


i have tried many methods of completely remove all trace of AMD stuff and re-installing.



with that 12.10 driver package i downloaded. i went under "custom" to see what actually installs

i see only 3 things

1. AMD Catalyst Install Manager
2. AMD APP SDK Runtime
3. HDMI/DP Audio Driver.


no Catalyst Control Center on that list.


help please!!!! this is so simple and i can't even do it....so frustrating!!!

have you installed your gpu properly in mobo??? detach your gpu then again seat it well in pci e slot ,,remove all previous driver you can use driver sweeper to remove leftover files

then install driver with EXPRESS option..don't install via custom..it might omit installation of ccc...
m
0
l
November 5, 2012 4:20:17 AM

ok i solved!

since this is an OEM card from Dell, the only driver works is the one from dell.

this oem card doesn't get any support from AMD directly
m
0
l
!