Sign in with
Sign up | Sign in
Your question

Why can't I transfer large photos across my wireless network?

Last response: in Wireless Networking
Share
December 28, 2011 4:40:09 PM

Hello, I've got a home network running on a Linksys WRT150-N router. The network consists of 2 desktops running Windows XP SP3, and a laptop running Windows 7. I am able to transfer various files without a problem between and among all machines, EXCEPT when those files are beyond a certain size (less than 1 MB or so transfers fine). Most of my photos are in the 2 MB - 3 MB range, so I have to run around like an idiot with a thumb drive to transfer them.

Is there anything I can adjust on my router or for my network settings that will allow me to share larger files?

Additional Details
The error message I get is different for Windows 7 or XP. On the remote XP machine, it says "Cannot copy filename: Access is denied. Make sure the disk is not full or write-protected, and that the file is not currently in use." Obviously, none of those conditions is true.

More random symptoms:

It seems that the problem is limited to JPG files, and appears to be affecting only the vast repository where I keep all my photos. I've got all my photos stored in a main directory, then in sub-directories by Year, then by Date. e.g. PHOTOS 2011 2011_12_25

Moreover, this problem does NOT appear to have much to do with file size. Some large files will copy, while others will not.

It's very random. Some sub-folders are filled with readable pictures, while others are unreadable. But this follows no discernible pattern based on file date -- and they were all taken with the same camera.

Smaller files seem to always be readable, even when larger ones in the same directory are.
December 28, 2011 5:11:55 PM

Is this problem limited to wireless, iow, do wired connections work ok?

How are you copying files? Using Windows Explorer?

Anything unusual about the filenames? Unusual chars? Names particularly long?

As a work around, try ZIPing up the files and transferring the ZIP file. I'd be interested to see if you had problems unzipping those same files if you did.
m
0
l
December 29, 2011 5:53:00 PM

I only have one machine wired to the router, and that connection works fine. All other wireless connections also work (e.g. wireless machines/devices to printer, internet, and each other.) Moreover, some files copy just fine, while others will not. But it seems to be on a directory-by-directory basis, and only within a particular directory structure -- the one with all my photos.

Yes, I am attempting to copy via Windows Explorer.

The filenames aren't unusual nor long. I have them sorted in a folder by year, then by date. There are about a dozen years, each with anywhere from 20 to 80 date subdirectories. Here's a sample of how the directories are set up:

C:\Documents and Settings\All Users\Documents\My Pictures\digicam\2009\2009_10_31\20091031_5148.JPG
or
C:\Documents and Settings\All Users\Documents\My Pictures\digicam\2009\2009_10_31\IMG_5148.JPG

Note: The directory structure I use is also part of Windows' Shared Documents scheme, so it appears as:
Shared Documents\Shared Pictures\digicam\2009\2009_10_31\20091031_5148.JPG
I don't see how that would matter, but I thought I'd mention it!


The filenames themselves are always the same in form: either YYYYMMDD_XXXX.JPG or IMG_XXXX.JPG.

Now here's a thing I just discovered. It looks like when I used to download images from my camera, the individual filenames would be in the YYYYMMDD_XXXX.JPG format. But recently the filenames have been switched over to the IMG_XXXX.JPG format. And apart from a few images from the beginning of this year, the more recent images -- the ones with the shorter filenames -- seem to be the ones that are not accessible on the network.

So my best guess now is that the shorter naming convention confuses the network somehow. The fact that these files are A) uniquely named in consecutive order, and B) kept in separate directories, doesn't seem to matter. Confusing!

I tried doing a mass rename of the files in one of the problem directories, but the files still don't display on the remote machines.
m
0
l
Related resources
January 5, 2012 3:23:10 AM

Giving this a little bump. It wants me to select a best answer, but I haven't gotten one yet.
m
0
l
January 12, 2012 2:17:06 PM

I had a very similar problem just now with the same error message on an all-XP network.
I went to the remote (wirelessly connected) PC and turned off the read-only attribute for the entire folder of interest, without checking which files were read-only (the read-only checkbox was grey when all files were selected). This enable me to zip the files I wanted while at the remote PC. Strangely, I could not zip them as a group (error creating zip file) so after zipping two files, I dragged the rest to the zip file one at a time.
I was then able to copy the zip file via Windows Explorer on the LAN, and unzip it without a problem.
The jpg files that will not copy (in the usual Windows Explorer drag-and-drop manner) will not display Summary Properties when looked at from the destination PC. This is the only common factor I can spot.
m
0
l
December 5, 2012 3:35:00 PM

I'm still having this problem, and haven't been able to find answers anywhere. It seems that I'm limited to around 1MB - 2MB as a maximum file size for transfer across my wireless router -- a Linksys WRT150N. I have the problem regardless of which machines on my network are involved: Windows XP box, Windows 7 laptop, and MacBook Pro. Smaller files transfer just fine, but over 1 or 2 MB, I get an access denied message.
m
0
l
December 5, 2012 4:26:54 PM

I think my frustration helped me figure out what the problem is: filename and path length.

After some exhaustive moving and renaming experiments, I'm reasonably certain that my issue stems from having too deep a file structure and folder/file names that are too long.

For example, the shared folder on my Windows box is: "Shared Documents" and within that I have a folder called "My Pictures". The file nesting goes deeper, so I end up with something like:

smb://RemoteComputer/Shared Documents/My Pictures/Family Photographs/2012/November/Dance Recital/2012_11_19_2334.JPG

(Note: I thought that the character limit was 255, and even allowing for spaces written as %20, it doesn't seem to add up.)

In any case, I think moving my photos into a different, less-nested directory structure will solve my issues.
m
0
l
!