Upgraded build not booting

I'm trying to upgrade my mobo, cpu, memory and graphics card. I threw everything together and it did not boot, so now I'm going trying to figure what the issue is.

Parts:
- ASRock 970 EXTREME3 (NEW)
- AMD Phenom II X4 965 (NEW)
- ASUS Radeon HD 6670 (NEW)
- G.SKILL Ripjaws Series 8GB (2 x 4GB) 240-Pin DDR3 1600 (PC3 12800) (NEW)
- OCZ ModXStream Pro OCZ500MXSP 500W ATX12V V2.2


Front panels light up, fans turn on, no boot beep.

Tested memory in old mobo, one stick at a time.
--Memory works fine

Tested graphics card on old mobo.
--Graphics card works fine. Had to download Windows 8 drivers manually from website.

Possible mobo or cpu issue. Or some cable not connected right.
I also had trouble putting in the heatsink for the cpu and ended up using a lot of force. Could that have damaged the cpu? Should I take that apart and check?
5 answers Last reply
More about upgraded build booting
  1. this one is really long tips but it can save you from getting headache
    http://www.tomshardware.com/forum/261145-31-perform-steps-posting-boot-video-problems
  2. Removed heatsink and checked that CPU pins are not bent. Reapplied thermal grease and reinstalled heatsink.

    Found and removed unused standoff

    Tried booting with only CPU/heatsink and 1 memory stick installed, and both power connectors and front panel and chassis speaker connected.
    --no boot
  3. Tried both 4 and 8 pin CPU power connector.
    Tried each ram slot.
    Disconnecter reset switch.
    Cleared CMOS by removing battery.


    still no POST
  4. should i return the motherboard?
  5. The motherboard is from Newegg and processor is from Amazon. I RMA'd the mobo, and if the replacement doesn't help, I will replace the processor as well.
Ask a new question

Read More

Homebuilt Graphics Cards CPUs Memory Systems