Sign in with
Sign up | Sign in
Your question

Pc won't POST with 7970.

Tags:
  • Graphics Cards
  • GPUs
  • Graphics
Last response: in Graphics & Displays
Share
November 8, 2012 6:42:24 PM

Good day everyone,

First let me tell you what my setup is, so everybody knows what I'm talking about:

CPU: Intel i7-3770K
CPU Cooler: Noctua NH-C14
PSU: Corsair CMPSU-750AXEU
GPU: Asus Matrix HD7970 Platinum
MB: Gigabyte GA-Z77X-D3H
Bootdisk: Samsung 128GB 2.5" SATA III SSD
Extra disks: 2 x Seagate Barracuda 2TB
Memory: Corsair Vengeance 4 x 8GB 1600MHz CL10 DDR3

Now I just installed this Pc today and when I first turned it on every fan was running.
Everything seemed fine, the green lights at the GPU where the PCI-e powercords connect went on.
But the pc wouldn't POST. So it did nothing, no Num-lock, no Capslock.. didnt do anything.

Then I decided to remove the GPU... turned Pc on again and now it did POST. So I installed Win7 and turned the Pc off again.
Now I put the GPU back in place, connect the power cords to the GPU and turned the Pc back on again... again no POST. So this machine wont POST with the GPU installed.

The monitor only works with the DVI port on the MB... NOT on the GPU... so if I turn off onboard stuff I dont get any output.

The fans and lights on the card do work, so the card isnt completly broken...

What could be the problem here, please help me out...thank you very much in advance.

Kind regards, :hello: 

Erik
NL

More about : post 7970

November 8, 2012 6:49:26 PM

Btw, I did the CMOS thing allready by disconnecting the PSU powercord.

Then hold a metal object to the 2 pins and pressed the ON button.

The clearing was succesfull because when I turned the PC on it said it was reseted and asked me which settings should be loaded.

but this DIDNT resolve my problem.

(I did all this when the GPU was installed).
November 11, 2012 9:43:30 PM

It's solved.
Related resources
November 22, 2012 4:02:48 PM

Xtobolic said:
It's solved.


Would you mind letting us know what the problem was? I'm having a very similar (if not the same) problem.

I have an ASUS Matrix 7970 GHz card. I can't get my new rig to post with this particular card installed, if I switch back to my old card (GTX 560 superclocked), the computer posts and works exactly as intended.

I'm running an 800w psu (from Corsair) that is less than a year old.

Thanks.
November 22, 2012 4:27:00 PM

Flashing my bios to the latest version solved it
!