Sign in with
Sign up | Sign in
Your question

GTX 690 not displaying

Last response: in Graphics & Displays
Share
November 9, 2012 9:08:04 PM

Hey,

So I just built my new system, I have an Asus GTX 690. Problem is I switched it on today and 2 out of the 3 DVI ports at the back have suddenly decided to stop working after working fine for weeks. I have it plugged in to my monitor with HDMI using the DVI to HDMI adapter that came with the card. I get "No Display" with 2 to of them and it works fine with one.

The reason I bought a 690 is because I plan to have a multiple monitor setup later next year but now if 2 of the ports are not working I wonder if the card could possibly be faulty? This is my first build so I am inexperienced with this sort of stuff. I have been tweaking games in the Nvidia Control Panel but apart from that I don't recall touching anything that could have caused this to happen :??: 

I'm now wondering whether or not to replace the card?

I have been monitoring temperatures inside my case and the card itself has not gone above 60 degrees. That was when playing Battlefield 3 so I don't think any damage has been done.

Thanks in advance for an replies!

More about : gtx 690 displaying

November 9, 2012 10:11:53 PM

I don't know if this makes any diference but after researching my graphics card I found out that 2 of the DVI ports are DVI-I and only one is DVI-D. Could this be the source of my issue? I am connecting to my monitor using a DVI to HDMI adapter then straight into the monitors HDMI port.

Thanks
a b U Graphics card
November 10, 2012 12:23:34 AM

So wait what is you current setup... one or three monitors at this time??

All three monitor must use the same connection type, youre say that you have one monitor plugged in via HDMI!

Related resources
November 10, 2012 1:29:44 AM

I have one monitor atmbut i plan to get another 2 early next year. My issue is the DVI port that my ONLY current monitor decided to stop dispaying this morning for no reason. It was working perfecly fine yesterday and has worked fine for weeks so I plugged it into my other DVI port on the GPU and still no display. Then plugged it into another one and it worked fine so my issue is I need to figure out why two of the three DVI ports on my GPU suddenly decided to stop working BEFORE I get another 2 monitors.
November 10, 2012 1:32:10 AM

Also the output on the GPU is DVI but I use a small DVI to HDMI adapter that came with the 690 to plug in an HDMI able which then plugs into my monitor.
a b U Graphics card
November 10, 2012 2:42:34 AM

restore Nvidia Control panel settings, what kind of monitor do you have? No DP port??
November 10, 2012 3:13:28 AM

redeemer said:
restore Nvidia Control panel settings, what kind of monitor do you have? No DP port??


Unfortunetely I have already tried restoring Nvidia Control Panel, no luck there. And my monitor is an Asus VE278Q and I do believe it has a display port.

Thanks
December 15, 2012 8:25:51 AM

hello! ErmCanthink:
i have got the same problem as yours, would you tell me about solution, did you get replacement card, or you sort it out by yourself, is it hardware problem or software problem?
many thanks
!