Sign in with
Sign up | Sign in
Your question

Computer didn't POST, now won't turn on?

Tags:
  • New Build
  • Computer
  • Systems
Last response: in Systems
Share
December 27, 2012 1:29:34 PM

Alright, so yesterday I built a computer (parts below) and when I went to turn it on, it turned on, but nothing happened on the monitor, didn't even leave standby. I double checked all wiring and only used 1 memory stick but still nothing. So then I replaced the memory, removed the BIOS battery and tried again, still nothing.

At that point I wondered if it was my graphics card, so I switched the card out with an AMD Radeon HD 3870 and turned it on. This time nothing happened at all, as in nothing powered on at all. At this point I went to the internet on another computer and got to a troubleshooting page here, which said to make sure you have the power plugged into the graphics card, which I didn't do (yeah it was a stupid mistake). So I plugged the first graphics card back in, plugged in the power, and this time it wouldn't power on like before. So I know the solution to one problem, but now it won't turn on so I can test the solution! Any Ideas as to why it is not turning on?

Specs:
AMD Phenom II X4 965 BE @ Stock 3.4Ghz Processor
ASRock 970 EXTREME3 AM3+ 970 ATX AMD Motherboard
Corsair Builder Series CX600 600W ATX12V Power Supply
G.Skill RipJaw Series 16GB (4 x 4gb) 240-pin DDR3 Desktop Memory (only using 2 out of the 4)
Rosewill CHALLENGER ATX Mid tower case
AMD Radeon HD 4850 X2 Graphics Card

If I left any details out just ask.

More about : computer post turn

Related resources
!