New build not working

So I posted this on the Homebuilt forums, but wasn't getting any help so I thought maybe I should post it here..
Also, I've already been through the checklist..

So I finally got the money together to order parts for my first build and after putting it all together inside the case I tried to turn it on, but nothing happened. The fans didn't turn on, nothing came up on the screen, nothing.

So I looked around to see what I could do. I tried resetting the CMOS, breadboarding it then shorting the PWR to turn it on, trying to power it on with just the cpu, cpu fan, and one stick of ram and it all ended in the same result. Nothing.

I also checked the PSU with the paperclip trick and it turns on fine.

So I'm thinking that maybe the problem could lie in the motherboard? If it is should I RMA it and get another?

Also, I made sure to touch the metal case frequently to make sure I discharge any static I have on me.

Parts list:
Intel Core i3 2120 3.3 GHZ
Gigabyte GA-H61M-DS2 Micro ATX LGA1155
Corsair Vengeance 4GB (1 x 4GB) DDR3-1600
Western Digital Caviar Blue 500GB 3.5" 7200RPM
Sapphire Radeon HD 7770 1GB
Corsair 500W ATX12V
Thermaltake V3 Black AMD Edition
3 answers Last reply
More about build working
  1. ^^x 2 after if everything that it said in this thread is done and nothing is working, come back and we will try to help you the best way we can :)
  2. Yep, I've been through it already last night. I'm going to RMA the mobo.
Ask a new question

Read More

New Build Systems