Sign in with
Sign up | Sign in
Your question
Closed

Sapphire hd 6850

Last response: in Graphics & Displays
Share
November 11, 2012 6:10:20 AM

hi everyone i just install my new sapphire hd 6850 on my mobo msi gf615m-p33 and i don't get any display!!! any help would be appreciable!!!

More about : sapphire 6850

a b U Graphics card
November 11, 2012 8:20:24 AM

Think i've found a problem, it's possibly down to incompatability of PCI E between the motherboard and GPU.
The motherboard is PCI E 1.0 and GPU is PCI E 2.0.
Also check you have it in the right PCI E slot on your motherboard and if that doesn't work....
You're gonna need a motherboard buddy!
November 11, 2012 9:12:05 AM

yeah but l have seen other users with the same board and GPU and its works perfectly!!!
Related resources

Best solution

a b U Graphics card
November 11, 2012 9:40:30 AM
Share

PCI-e is backwards compatible so there should be no issue!

Try the following
Disable onboard graphics from the OS and the BIOS

Check if the power connector for the GPU is properly inserted

See if the fans powerup to check for PSU problems

Lastly try the card in a friend's PC to see if it works

Also what wattage is your PSU?
a b U Graphics card
November 11, 2012 9:44:57 AM

Haha props jai, i was going to suggest check the power connector but i figured that was a no-brainer :s
November 11, 2012 1:50:30 PM

its a 500 watt PSU finally its work thank you all for your suggestion but now i am having driver issues my screen turn dark when i finished install the driver!!!! very unlucky i am downloading the latest drivers to try to resolve this issue!!!
a b U Graphics card
November 11, 2012 1:52:26 PM

okay good luck! :) 
a b U Graphics card
November 11, 2012 2:47:18 PM

You need to be more specific whenever possible (with links to your hardware in question). Which 6850? What 500W PSU. What drivers? The ones off the CD or downloaded. Catalyst 12.10 are the latest official release drivers while 12.11 are the latest beta drivers.

PCIE 3.0 cards are compatible with PCIE 1.0. No such thing as a compatibility issue as far as that's concerned.
November 12, 2012 9:34:46 AM

sapphire hd 6850 vapor-x 1gb256bit ddr5
XGR extreme power 500w
downloaded catalyst 12.10
mobo msi gf615m-p33
samsung syncmaster s20b300 led 20"
Amd athlon II x3 440

Now the problem i am getting is some flickering horizontal line or dots from time to time!!! Please Help
November 12, 2012 10:53:32 AM

thanks everyone for all your help its was just a simple issue with catalyst setting now working perfectly too happy thanks again!!!
November 12, 2012 10:54:29 AM

Best answer selected by nicholaslindor.
!