Sign in with
Sign up | Sign in
Your question

Just built a PC not powering up, need help!!

Last response: in Systems
Share
December 28, 2012 12:07:52 AM

Ok so I built a computer, and now when I press power it turn on for a secondary and then turns off. Need help badly!!!

Specs: Case:IN WIN GRone Gray 0.8mm SECC Steel ATX Full Tower Computer Case

CPU:Intel Core i7-3770 Ivy Bridge 3.4GHz (3.9GHz Turbo) LGA 1155 77W Quad-Core Desktop Processor Intel HD Graphics 4000 BX80637I73770

MotherBoard:GIGABYTE GA-Z68XP-UD3P LGA 1155 Intel Z68 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboard

RAM:G.SKILL Ripjaws X Series 32GB (4 x 8GB) 240-Pin DDR3 SDRAM DDR3 1866 (PC3 14900) Desktop Memory Model F3-1866C10Q-32GXL

Graphics Card: EVGA 02G-P3-1568-KR GeForce GTX 560 Ti (Fermi) 2GB 256-bit GDDR5 PCI Express 2.0 x16 HDCP Ready SLI Support Video Card

Power supply: Rosewill CAPSTONE Series CAPSTONE-750 750W Continuous @ 50°C, 80 PLUS GOLD Certified, Single +12V Rail, ATX12V v2.31 / EPS12V v2.92, SLI Ready, CrossFire Ready, Active - PFC Power Supply

SSD : OCZ Agility 4 AGT4-25SAT3-256G 2.5" 256GB SATA III MLC Internal Solid State Drive (SSD)

HDD : Western Digital WD Black WD1002FAEX 1TB 7200 RPM 64MB Cache SATA 6.0Gb/s 3.5" Internal Hard Drive -Bare Drive

More about : built powering

a b B Homebuilt system
December 28, 2012 1:36:45 AM

Do you have both the 24 pin power cable and the 8 pin CPU power cables connected? If so, try booting with just the CPU, one stick of RAM and onboard graphics.
m
0
l
Related resources
!