Sign-in / Sign-up
Your question

BT Home Hub Unlocking and Use Help

Tags:
  • Configuration
  • IP
  • WAN
  • DHCP
  • Wireless Networking
Last response: in Wireless Networking
December 30, 2011 7:07:10 PM

Hi I have a BT Home Hub 2.0A that I want to unlock touse on my cable Virgin Media broadband.

So I followed an unlocking process for the BT HH 2.0A and the instructions on how to get the ETH4 working (im totally a newbie to this)

Now heres where Im going wrong!

Im doing the telnet and loggin into the routher and see the cracked login part.

However when im entering the commands on that page e.g

:p pp relay flush
:p pp flush
:eth flush
:atm flush
:atm phonebook flush
:eth bridge ifdelete intf=ethport4
:eth ifadd intf=eth_wan
:eth ifconfig intf=eth_wan dest=ethif4
:eth ifattach intf=eth_wan
:ip ifadd intf=ip_wan_eth dest=eth_wan
:ip ifconfig intf=ip_wan_eth status=up
:ip ifattach intf=ip_wan_eth
:nat ifconfig intf=ip_wan_eth translation=enabled
:D hcp client ifadd intf=ip_wan_eth
:D hcp client ifconfig intf=ip_wan_eth metric=5 dnsmetric=5
:D hcp client rqoptions add intf=ip_wan_eth option=dhcp-lease-time
:D hcp client rqoptions add intf=ip_wan_eth option=dhcp-renewal-time
:D hcp client rqoptions add intf=ip_wan_eth option=dhcp-rebinding-time
:D hcp client rqoptions add intf=ip_wan_eth option=subnet-mask
:D hcp client rqoptions add intf=ip_wan_eth option=classless-static-routes
:D hcp client rqoptions add intf=ip_wan_eth option=default-routers
:D hcp client rqoptions add intf=ip_wan_eth option=classfull-static-routes
:D hcp client rqoptions add intf=ip_wan_eth option=domain-name-servers
:D hcp client ifattach intf=ip_wan_eth

I get stuck on:
:eth bridge ifdelete intf=ethport4

Now... If i have my laptop connected to the hub on 1,2 or 3 of the ethernet ports when i run this one command I get the error:

Invalid interfact name
Bad value for parameter 'intf'
Unknown Command.

[attachment=0]ololol.png[/attachment]


But all the other commands run fine, i tried plugging the ethernet from my cable modem into ETH4 and connecting (wireless and hardwire) but still had no internet connection.

So then i tried running the list when connected to the Hub on ETH4, when i ran the :eth bridge ifdelete intf=ethport4
Command it simply booted me fromt he router (im guessing this disables ETH4 or something?)


Ok so THEN i thought maybe if i run the commands plugged into ETH4 and then when it boots me plug into ETH1 i can carry on wiht the commands, which I did but when i tested the internet again it did not work!

Im stuck and i would really appreciate any help!

Thank you for the great tutorials
Ash

More about : home hub unlocking

December 31, 2011 3:53:11 AM


Hello and welcome to Tom's Hardware Forums.

Whenever I want to reuse an old HomeHub - which isn't often because I regard them as useless - I simply set it as an access point and only use it for its ability to transmit what it receives from a separate MODEM. Why hack when the answer was in the settings all along.

I can't tell you right now how I do it because I don't have one to mess around with but it can work without an ADSL signal coming through it from the telephone. Any port will do as an uplink.
December 31, 2011 9:16:49 AM

Ok well ive unlocked it and ran those commands. I have a cable MODEM but my Belkin router is broken, so i wanted to use the home hub as a router, im not bothered about the moden aspect.

Could you link me to a tutorial on how to use it as a router?

Thanks for the reply!

Ash