Sign in with
Sign up | Sign in
Your question

6850 artifacting/flickering only in 1080p 2D mode

Last response: in Graphics & Displays
Share
November 12, 2012 2:54:53 AM

So, I have a XFX 6850 that has started artifacting/flickering. This only happens when I'm moving my mouse or typing, and it only happens when I'm doing low-GPU tasks like browsing the web, opening programs, using Word & Excel. It never occurs when I'm watching videos or playing games. Funny thing is that when I'm surfing the web, it will start artifacting/flickering severely, but when I open another tab and play a youtube video, the artifacting/flickering will magically stop. It also stops when I switch to a resolution lower than 1080p (which is my monitor's native resolution).

I've troubleshooted extensively, and the cause of this issues is not my monitor, cable, mouse/keyboard, other system components, or driver/firmware versions. My guess is that my video card is going bad, or that AMD's drivers have a bug that causes the 2D mode to run poorly.

I'm able to RMA, but I don't want to spend money & time shipping it back if there's a quick fix, or if my video card isn't defective. Help would be appreciated.
November 12, 2012 2:27:55 PM

You did not list the hardware and OS.

But generally try this:
Sign in as administrator (If you are not administrator you may be blocked)
Close all the applications that are being used...save and close your files...
Turn Off the antivirus and firewall, turn off the functions of windows defender.
If you have multiple security programs installed, they must be turned ALL off. Security will prevent your driver from installing...
Download the latest CCC driver package, and save it to an easy location. Make sure this is the correct driver for your card.
Delete all the current AMD video software and drivers, restart the system (the video will look screwy, don't worry)
Now load install all the newest CCC drivers and restart the system (the driver will not work (yet) as you said, but load it anyway)
left click start
left click computer
right click C drive
Left click Open
Right click Users
Left click properties
"Check" mark the box that says: Attributes: "Hidden" (there is now a check-mark in the "Hidden" box)
Click: "Apply"
Now the system will apply the hidden attributes...and this will take a while, or maybe a long while. Let this proceed, and don't interrupt it...
During this procedure, a message may inform you that you do not have administrator privilege to the file you are trying to change the attributes of. That's OK. Just click: "ignore all."
When this procedure is finished, click OK (the box will close after you click OK)
Now you will once again be looking at folders in C drive (don’t close the C drive window or you may regret it)
(once again) right click Users
(once again) left click properties
UN- check the box that says: Attributes "Hidden" (you will now take the check mark OUT, Hidden is no longer checked)
Click Apply
Now the computer will UN-apply the hidden attributes, and it may take a while, or a long while...but let it proceed, and finish, don't interrupt it.
During this procedure, a message may inform you that you are not the administrator of the file that you are trying to change the attributes of. That's OK, just click: "ignore all."
When this is completed click OK
Now close all windows and restart the computer
turn all the security back on.
At this point, the CCC should be functional. Open the CCC and test

One thing is to make sure that the priority of the game is highest; there maybe other processes running that have priority over the game.
Including for instance security programs and antivirus. The latest of which have gaming modes.
If there is not a gaming mode on the security try turning it OFF. Now test it with the security turned off. Multiple mismatched security programs can cause conflicts.
“Free” security downloaded from the internet can cause lots of problems…



Another good thing is to eliminate as many unused / junk / UN-needed applications.
Try to get rid of resource hog, un needed / unnecessary applications.
turn off the screen saver
Go into the power profiles,
set standby, hibernate and sleep to OFF
leave the monitor standby ON, that's OK (maybe not, try OFF)
Set the Hard Drive standby to NEVER
Set system Performance to MAXIMUM, not "quiet mode."

Open the bios set up and make sure "cool and quiet" is OFF. (AMD)
There may be a performance setting in the bios setup you have...make sure it's cranked up to max.
in the bios, see that the allocation for video, if available, is maxed.

Now open the hardware manager profiles...
click start
click computer
click system properties
click device manager
double click on mice and other pointing devices
right click on HID compliant mouse
left click on properties
click on the power management tab
UN-check the box that says: "allow the computer to turn off this device to save power." (there is now NO check mark in this box)
click OK

Now repeat this procedure for all mice, monitors, keyboards, and ALL USB ports on the device manager list.

You must open ALL the devices one at a time, as above, and turn off the power saver, for each device.
November 14, 2012 7:35:17 PM

Did you solve this issue somehow? I started having the exact same issue just two days ago as well. Maybe a new update that got pushed through? Imma try and install an older driver tonight. This problem is really annoying.
Related resources
November 15, 2012 2:57:57 AM

Hey, here's what worked for me, Charlie. I uninstalled the AMD drivers through the Catalyst uninstaller. Rebooted in Safe Mode and used Driver sweeper to clean up the dregs. Screen went all Win95 on me, of course. I then installed the beta drivers, version 12.11. Worked like a charm, no screen flicker upon reboot. Hope this helps.
November 22, 2012 12:47:46 AM

I figured it out. AfterBurner is causing this. I have it set to only apply settings when AB is open, but it is definitely doing something even when it's not running. Uninstalling it did the trick; no more artifacting.

Hope this helps. Who would have guessed that AB is still bugged after how many revisions/updates?
!