Sign in with
Sign up | Sign in
Your question

New Build Smoke!

Last response: in Systems
Share
December 28, 2012 7:59:45 PM

Hi all,

I just built the new mini ITX with:

Asrock z77E
i5-2500k
WD Caviar Black 1 TB
MSI 7770 GHz edition
Cooler Master Elite 120 case
Corsair HX650 PSU

Anyway, I did an external build and everything worked fine. I just daisy chained the two case fans and turned it on and smoke poured out. It came from between the chassis fan connector and the first molex plug which was connected to the 80 mm case fan. Now the graphics card doesn't work either. I hooked the HDMI direct to the box and I have a display, so everything else seems fine. I have one more set of molex connectors from this PSU that I can try again with. Should I try it again?

I also noticed where the GPU connects to the mobo, some of the gold was chipped off where it goes into the PCI-E slot - does that matter?

Thanks so much - I'm so disappointed!

More about : build smoke

December 28, 2012 8:28:43 PM

I also meant to say that everything (except the graphics card) works fine WITHOUT the case fans hooked up. But, I can't run it like that I know :pt1cable:  I hadn't hooked up the fan for the GPU yet either, so it was definitely the case fans - the plastic cover burned right off the copper wire going to the mobo.
m
0
l
December 28, 2012 9:53:56 PM

Ok, one more thing I just discovered. One of the two wires coming from where the fan connects itself to it's molex just pulls right out. I noticed a little silver sticking out and I gently pulled and out came the silver wire, so there was no connection being made. Meaning, that only one of the two wires was actually connecting. Could this be the problem? If the 120mm fan is still ok, I could try connecting that again. But, I only have one more molex connector for the PSU...
m
0
l
!