Sign in with
Sign up | Sign in
Your question

7970CF Low Usage, Low FPS.

Last response: in Graphics & Displays
Share
November 12, 2012 12:37:26 PM

So, i used to own 2 6970's which used to run bf3 fine, but had to give them away to a friend.
So i decided to buy 2 Gigabyte 7970's thinking these would last me a few years.

ran Bf3 for a few days running perfectly over 100FPS, but now cant seem to get more than 60 unless scoped in with sniper. I ran MSI afterburner to check if CF was working properly, which it was but cards were running from 55-70% which i'm wondering if that is the issue? Running metro 2033 runs superb, averaging the performance it should be and running at 90%+usage..
Boarderlands two seems to be having the same issue as BF3.. The campaign on the other hand runs 90%+ like it should also.


Specs:
Asus Rampage Extreme III
i7 960 3.2Ghz
12gb G.skill Sniper 1600hz Ram
2x Gigabyte 7970 GV-R7970OC-3GB
TX-850
Corsair GT 120gb
12.11 Beta Drivers (I've tried others, with no change)
Samsung S27A750 120Hz

Reformatted to Windows8 hoping for Better performance but Nothing. (Reason for the two cards on 1 screen, is to get the 120fps+ on gaming to look nice at 120hz..)
a b U Graphics card
November 12, 2012 12:40:51 PM

Your CPU could be a slight bottleneck. Not that is a extreme hold back but its probably whats keeping you held back in the BF3 multiplayer and Borderlands 2
m
0
l
a b U Graphics card
November 12, 2012 12:50:54 PM

Did you change drivers recently? I don't cf, but with my 7870 I have trouble in a lot of games with 12.10 or 12.11. I have to use 12.8. How hot are the cards getting? Also, what is the cpu usage like in game? If it is 100% that's your problem.
m
0
l
Related resources
a b U Graphics card
November 12, 2012 12:53:04 PM

Rockdpm said:
Your CPU could be a slight bottleneck. Not that is a extreme hold back but its probably whats keeping you held back in the BF3 multiplayer and Borderlands 2

That wouldn't make sense since the OP stated that BF3 initially ran at 100+FPS with his setup, and only after a while ran slower.

I highly doubt this is the problem but make sure you don't have any custom profiles set for those games in CCC under the Gaming section. And make sure that there isn't a custom global profile set (Although that's very unlikely since you said Metro is running fine).
m
0
l
November 12, 2012 12:54:13 PM

Ive tried ocing CPU up to 4ghz but that didnt make a difference,
Usage of CPU sitting around 65% never going over 85%,

When in intense situations the GPU usage goes down rather than up, along with the FPS.

Ive tried with HT off and on, off made it perform worse.

Cards are running no more than 70Degrees.
m
0
l
November 12, 2012 12:59:52 PM

rene13cross said:
That wouldn't make sense since the OP stated that BF3 initially ran at 100+FPS with his setup, and only after a while ran slower.

I highly doubt this is the problem but make sure you don't have any custom profiles set for those games in CCC under the Gaming section. And make sure that there isn't a custom global profile set (Although that's very unlikely since you said Metro is running fine).


And no CCC profiles have been ever created, all is set to "use application settings"
i always turn VSync off also, hate the Delay from the monitor to the mouse.
m
0
l
a b U Graphics card
November 12, 2012 2:15:59 PM

rene13cross said:
That wouldn't make sense since the OP stated that BF3 initially ran at 100+FPS with his setup, and only after a while ran slower.

I highly doubt this is the problem but make sure you don't have any custom profiles set for those games in CCC under the Gaming section. And make sure that there isn't a custom global profile set (Although that's very unlikely since you said Metro is running fine).

Look man, I gave my 2 cents. to say i'm wrong is one thing. but to say i'm wrong then use my point as your own is taking credit in my book.
m
0
l
a b U Graphics card
November 12, 2012 2:19:12 PM

I am about 99% sure this is a driver issue, since BF3 works well with cf. Try 12.6, 12.8, 12.10, 12.11b4. Use driver sweeper between each install to make sure you completely remove one before trying the next. Start at the newest and work your way back. You said your cpu usage is 65-85% so that is a nonissue. You said your temperature is at 70C, which is good.
m
0
l
November 13, 2012 12:58:39 AM

wanderer11 said:
I am about 99% sure this is a driver issue, since BF3 works well with cf. Try 12.6, 12.8, 12.10, 12.11b4. Use driver sweeper between each install to make sure you completely remove one before trying the next. Start at the newest and work your way back. You said your cpu usage is 65-85% so that is a nonissue. You said your temperature is at 70C, which is good.


Okay, i will try this step next, Once i get home from work.
i'll reply in about 8hrs.
m
0
l
November 13, 2012 12:46:13 PM

Okay so tried a few drivers, yeilding best results from RC11 drivers but was causing micro stuterring. after was 12.8, which was stable and gave about 5% increase in usage and FPS

http://i.imgur.com/PQJze.png

ive added a pic of usage, the high spikes are when i zoom in with scopes, which when i zoom in seems to make the usage go up to about 95% and giving 150frames.. I dunno whats going on..
m
0
l
a b U Graphics card
November 13, 2012 12:58:09 PM

95% usage sound good. How is it working in game now?
m
0
l
November 13, 2012 1:09:37 PM

Its a bit better, about 5% improvement on 12.8. The usage always went way up along with my frames when i zoomed in with a scope 4x or more.. not sure why when the Usage should go down as its not displaying as much on the screen.
m
0
l
a b U Graphics card
November 13, 2012 1:16:01 PM

If you don't have vsync on it seems like you cards should always run at 99% usage since they are always pushing as many frames as possible, unless you have a cpu bottleneck which you dont.
m
0
l
November 13, 2012 1:18:50 PM

yea... I have no idea whats going on..
i always turn VSync off also, hate the Delay from the monitor to the mouse.
Considering RMA'ing both cards..

singles they run properly, but only giving like 60frams..
m
0
l
November 13, 2012 2:12:23 PM

wadawada55 said:
So, i used to own 2 6970's which used to run bf3 fine, but had to give them away to a friend.
So i decided to buy 2 Gigabyte 7970's thinking these would last me a few years.

ran Bf3 for a few days running perfectly over 100FPS, but now cant seem to get more than 60 unless scoped in with sniper. I ran MSI afterburner to check if CF was working properly, which it was but cards were running from 55-70% which i'm wondering if that is the issue? Running metro 2033 runs superb, averaging the performance it should be and running at 90%+usage..
Boarderlands two seems to be having the same issue as BF3.. The campaign on the other hand runs 90%+ like it should also.


Specs:
Asus Rampage Extreme III
i7 960 3.2Ghz
12gb G.skill Sniper 1600hz Ram
2x Gigabyte 7970 GV-R7970OC-3GB
TX-850
Corsair GT 120gb
12.11 Beta Drivers (I've tried others, with no change)
Samsung S27A750 120Hz

Reformatted to Windows8 hoping for Better performance but Nothing. (Reason for the two cards on 1 screen, is to get the 120fps+ on gaming to look nice at 120hz..)


I have two 7970's as well and the same drivers and I don't have any issues with Battlefield 3. I am not sure what is going on, but just wanted to put that in there for you.
m
0
l
November 13, 2012 2:22:43 PM

Thanks beethree, have you tried those cards on a system with Worse CPU? or stock clocked CPU?

I just tried running crysis2, usage is 95% when nothing going on avergaing 120fps, then once action usage drops to 50% and FPS hits 50fps.
m
0
l
November 14, 2012 12:07:05 PM

tried it with the un-installation of MY xonar STX drivers, thinking the driver might be colliding but that didnt work, another upload of levels.
http://i.imgur.com/z13bu.png

just noticed that 1 card is a bit different so may be a generation of the same card but a bit older, could this be an issue? 1 my have a newer bios or something?
thanks for ur support guys.
m
0
l
November 14, 2012 6:56:41 PM

Did the problem start happening after you installed afterburner? How were you measuring FPS prior to using afterburner? Reason I ask is because afterburner could be conflicting with the catalyst control center. Since you have afterburner installed, I'd recommend going into the performance tab of the catalyst control center, click on overdrive then uncheck Enable Graphics overdrive and also make sure manual fan control is unchecked...do this for both cards (you can change cards at the top of the screen). After doing this, go into afterburner settings, and check the unlock voltage control (might need to use kernal mode to do this)...apply that, it will want to restart the program. Once afterburner is running again, change the power limit to atleast +10% (I run at +20). You can mess around with overclocking the GPUs if you want, but do that after you fix the GPU usage issue. Also, make sure that the synchornize settings for similar GPUs is checked. To ensure that both cards are clocked to the same level, look at the clock levels of the first card in afterburner...then go into settings and change to the second card, and then look at the clock levels in afterburner to make sure they are the same.

As for the BIOS, I wouldn't bother going that far just yet...both cards should work just fine together as long as they are clocked to the same level.
m
0
l
November 15, 2012 1:00:18 AM

Dude496 said:
Did the problem start happening after you installed afterburner? How were you measuring FPS prior to using afterburner? Reason I ask is because afterburner could be conflicting with the catalyst control center. Since you have afterburner installed, I'd recommend going into the performance tab of the catalyst control center, click on overdrive then uncheck Enable Graphics overdrive and also make sure manual fan control is unchecked...do this for both cards (you can change cards at the top of the screen). After doing this, go into afterburner settings, and check the unlock voltage control (might need to use kernal mode to do this)...apply that, it will want to restart the program. Once afterburner is running again, change the power limit to atleast +10% (I run at +20). You can mess around with overclocking the GPUs if you want, but do that after you fix the GPU usage issue. Also, make sure that the synchornize settings for similar GPUs is checked. To ensure that both cards are clocked to the same level, look at the clock levels of the first card in afterburner...then go into settings and change to the second card, and then look at the clock levels in afterburner to make sure they are the same.

As for the BIOS, I wouldn't bother going that far just yet...both cards should work just fine together as long as they are clocked to the same level.


now that i think about it.. it was around the same time, before i just used to use fraps, or in game settings if they had them. thanks for the advice i will try all those things and get back to you! :) 
m
0
l
November 15, 2012 10:15:07 AM

Okay, tried this. i just tried un-installing MSI afterburner, and just using in game FPS settings on BF3 with No result.. and boarderlands just used fraps.

i do know that the bios is different from what im seeing on the info, 1 card is 5 months newer.
m
0
l
November 15, 2012 10:25:39 AM

If it's the same style of card, you could save a copy of the newer bios and flash the other card. I can explain that better tomorrow, or you can google it. Another quick thing to try prior to flashing the bios...disable ulps on both cards, I'm exhausted but it is easy to find on google. Also there is a newer beta 12.11 that you can try. Not sure if there is a new CAPS
m
0
l
November 15, 2012 11:52:50 AM

removed ULPS but that was a negative on any results. Im currently using the 12.11 drivers atm just to try boost fps with the "Supposed" up2 20% boost.

Much appreciate the help. :) 
m
0
l
November 15, 2012 12:08:45 PM

I work at a computer store atm, awaiting stock of 7970 to come, going to swap it with a newer card.
m
0
l
November 15, 2012 9:55:02 PM

Have you used GPU-Z to check that both cards are running at the same clock and memory speeds? I'm wondering if one is a GHz edition and the other is a standard edition since they have different bios.

It still confuses me that your GPU usage drops to 50% I ran BF3 and BL2 for about 10 minutes each and then checked afterburner, my cards stay at around 95-100% usage except during loading screens....FPS always stays above 100 in both games, most of the time stays above 200 in BL2. My setup is a I-7 3930k @ 4.4GHz, Asus rampage extreme IV mobo, ocz agility 4 ssd in raid 0, XFX 7970 DD CF 1100 MHz clock and 1500 MHz memory.
m
0
l
November 16, 2012 1:59:58 AM

they are the same clock speed, 1000 by 1375
1 of the cards was released in april and the other card was released in september according to Hardware in CCC
m
0
l
November 16, 2012 2:14:58 AM

Hmm, do your cards have a dual bios switch?
m
0
l
November 16, 2012 2:50:07 AM

yes, i believe it does just read on the Gigabyte website.
Wierd thing is the bios that is on the newer card isnt even in the download list in gigabytes website.
m
0
l
November 16, 2012 3:02:51 AM

Hmm, that is odd. Is it possible that someone else might have flashed the bios? It doesn't have to be a gigabyte bios to work. Try flipping the switch on one card and see if it makes any changes.
m
0
l
November 16, 2012 3:09:59 AM

okay thanks, i will let you know in 2 hrs when i get home from work.
m
0
l
November 16, 2012 6:58:56 AM

switched to each bios, all where the same version. so newer card still has different bios to bottom..

I hope this is the issue because i can get replacement from work.
m
0
l
November 16, 2012 7:54:21 AM

I'm still a bit reluctant to think it is a bios issue since both card are at the same clock speed. You could save a copy of the newer bios using gpu-z then flash it using atiflash...I'd recommend the dos version over the windows version, just as an extra precaution.

Before you do that, what % do you have the power slider in CCC? I've heard some people say they have issues at +20%... I never have had a problem but I also overclock. I'd recommend setting at 10% and see if there is a change, if no change bump it to 15% This allows the card to draw more power, which is important since you are running cf.
m
0
l
November 16, 2012 8:31:54 AM

okay tried it at both, no change. also, tried running a single bridge and dual bridges single bridge made it perform worse. ill try this flash tool,
m
0
l
November 16, 2012 9:01:51 AM

ive tried to flash the card, but it says "cannot flash ROM"
m
0
l
November 16, 2012 9:10:41 AM

okay, so i tried flashing the older card's bios to the newer card, successful but then wouldn't reboot my computer. so had to switch the bios switch back over to the other bios.. :S
m
0
l
November 16, 2012 10:22:09 AM

Well damn, I was hoping that would fix it. Hmm, the only other things that I can think of are to try getting the newest bios for both cards from the gigabyte site. If that doesn't help, try using only one card at a time to see if the problem is isolated to a single card. What is your graphics score in 3dmark11?
m
0
l
November 16, 2012 11:11:57 AM

Ive tried using 1 card, it gave proper usage with around 60-80fps, i have to try the other 2nd 1.
Graphics score in 3dmark11 was around 16000
m
0
l
November 16, 2012 11:43:49 AM

Try running the second card by itself, but in it's current slot...just want to keep the variables at a minimum.
m
0
l
November 16, 2012 11:48:19 AM

I just ran 3dmark at your clock speeds, I got a total score of P15564 and a graphics score of 17345. I am running a 3930k at 4.4, but I don't think the graphics score would be much different if I dropped the CPU down.
m
0
l
November 16, 2012 1:58:21 PM

Your GPUs seem to be working very well in 3dmark, I don't think you have a GPU issue. Did you install or do any changes to directX? I'm thinking you have a software issue somewhere.
m
0
l
November 16, 2012 3:08:18 PM

Well i had windows7 and it wasnt working well so did a fresh install of windows 8 hoping for the performance benifits, and to fix any driver issues,but nothing..
m
0
l
November 23, 2012 7:52:45 AM

Okay, so finally i got me new cards, both with same bios and everything.
Did another clean install of windows..
and...
FUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU..
didnt work...
m
0
l
November 23, 2012 9:04:43 AM

Well damn, that sucks. Have you tried using a different crossfire bridge? Also, are you running the GPUs in the the x16/x16 setup?...if you don't know, it's pci slot 1 and slot 3 for CF setup (page 2-28 of the manual). I doubt the x16/x16 setup will make much of a difference though, but its worth a shot. How are the cards performing when used individually? Are you getting over that 60 fps limit? I think I get about 80 or so fps when using a single card on BF3 with ultra settings.
m
0
l
November 23, 2012 9:10:19 AM

Also, have you updated your chipset? Have you installed all of the C++ distributables (should have files that are dated from 2005 to 2012)? Are all of the directx files installed?
m
0
l
November 24, 2012 1:42:06 AM

Yea, ive tried a different CF bridge with no luck, and both cards are at 16x.
individually they work great pinging at 95% usage, averaging 50-70fps, so about the same as now when i have two cards in because they using only 50% (unless i zoom in with more than 4x scope, which then they jump to like high 80's to mid 90% usage)

updated chipset, sorry to sound noob but what du mean by that?
the mobo drivers? and ill check now about C++
directX is up2 date.
m
0
l
November 24, 2012 2:10:29 AM

Yeah by chipset, I mean motherboard drivers.
m
0
l
November 24, 2012 3:29:41 AM

Have you by chance installed the CAP profiles? I think they are at 12.10 now. Try downloading the latest one and make sure the old one is deleted. It will show up as application profiles in your programs list. Once you have the new one, go into CCC and change the crossfirex mode from default to use amd predefined profile, select bf3.exe and click apply. I normally don't use the profile, so I'm a bit reluctant to say that it will fix your problem, but it's worth a shot.
m
0
l
November 24, 2012 3:30:48 AM

Also, set the wait for vertical refresh in CCC to off. And make sure that your resolution in game is set to 120hz
m
0
l
November 24, 2012 6:35:51 AM

okay tried all that, little bit of improvement in BF3, sitting at around 75% but.. still dipping.
tried borderlands also, no difference in that.. =(
m
0
l
!