Sign in with
Sign up | Sign in
Your question

ESD damage

Last response: in Systems
Share
December 29, 2012 10:02:22 AM

First time build. I wore my static band the whole time until I went to turn it on. When I did, only a couple of fans turned on, but not the motherboard. I turned it off, and without the static wrap reached in to check that the main connector wasn't loose. Static. My luck. I know the PSU is gone for sure. What other parts could be damaged? Are all parts, even the hard drive and cables fans etc. susceptible? Sorry if wrong forum.
EDIT: I'm fairly certain the motherboard is gone as well as the burning smell is only there when its plugged in. Is there ANY chance the processor is still intact? Or the RAM?

More about : esd damage

a b B Homebuilt system
a c 435 V Motherboard
December 29, 2012 11:50:27 AM

You may have used the wrong ps connector, which could have burned up something. ESD damage is relatively rare, and doesn't result in a burning smell. It's more subtle. Please list your system specs. Could be just the power supply unless you see surface damage or burnt plastic somewhere.
December 29, 2012 12:52:52 PM

No visible damage. I saw a static spark from my finger when I touched the main connector, that's why I thought it was ESD. The specs:
Diablotek 675 watt ATX PSU UL series 24 pin main connector
ASRock H77 micro ATX 20+4 connector
Sorry if this stupid, but is an ATX power supply not compatible with a micro ATX mobo? And if that's the case, and my power supply is what was burning and it wasn't ESD, is my motherboard, CPU, etc. still salvageable?
Related resources
a b V Motherboard
December 29, 2012 12:58:36 PM

Gldemian said:
Diablotek 675 watt ATX PSU UL series 24 pin main connector


if that PSU is of the same quality as:
http://www.jonnyguru.com/modules.php?name=NDReviews&op=...

then it is complete junk

If the PSU blew, being that it could be a piece of crap (a link to where you bought it from with the price might be able to tell) it could have taken out some other components, its impossible to tell until you get a new PSU
a b B Homebuilt system
a c 435 V Motherboard
December 29, 2012 1:39:33 PM

I would breadboard your setup and try again. Use just the cpu/heatsink, one stick of ram, and your onboard video (if possible) on a non conductive surface such as a breadboard or a cardboard box. You can also reseat the ram in case it's not all the way in. The screwdriver trick is to move it around the case pin cluster until the system turns on. You may have to remove the power supply out of the case for the leads to reach the board.
December 29, 2012 1:44:45 PM

o1die said:
I would breadboard your setup and try again. Use just the cpu/heatsink, one stick of ram, and your onboard video (if possible) on a non conductive surface such as a breadboard or a cardboard box. You can also reseat the ram in case it's not all the way in. The screwdriver trick is to move it around the case pin cluster until the system turns on. You may have to remove the power supply out of the case for the leads to reach the board.

I'm assuming this is after I buy a new power supply? Or is it a worth a shot with this one even though I'm pretty sure it's completely gone?
a b B Homebuilt system
a c 435 V Motherboard
December 29, 2012 1:51:07 PM

That's your choice. Use your best justment. Normally you'll smell burning if the ps goes bad. One spark normally won't do it. If your vender will give you credit towards a different brand, check out antec, corsair, or ocz, all better brands than diablotec.

December 29, 2012 1:54:32 PM

There is burning, and it is every time I try to turn on the PSU. Nothing else, no movement, just the smell. Thank you guys. I'm hoping it is only the power supply.
December 29, 2012 5:38:42 PM

Hey guys. Bought a new PSU. Mobo still won't turn on. If its fried, does that mean my processor and ram were scrapped as well?
a b B Homebuilt system
a b V Motherboard
December 29, 2012 5:57:04 PM

Did you remember to put standoffs in the case so the motherboard wasn't touching it?

As for your question, it's a 'Maybe yes, maybe no.' Entirely depends on what happened.
December 29, 2012 6:14:12 PM

No I didn't... Didn't even know what they were. Could that have caused ESD damage bad enough that it won't turn on in just a couple of hours? Or is it more likely that my old psu fried it? I've got little to no clue what I'm doing at this point.
!