Sign in with
Sign up | Sign in
Your question

New build AMD A-series won't work with AMD drivers

Tags:
  • Radeon
  • Drivers
  • AMD
  • Graphics
Last response: in Graphics & Displays
Share
November 13, 2012 7:34:33 PM

Hello,
I built the following last week:
Windows 7 Ultimate
ASRock A55M-HVS FM1 Motherboard
RAIDMAX Altas ATX-295WBP case w/500w PS
AMD A4-3400 Llano 2.7GHz Socket FM1 CPU
G.SKILL Ares Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM
ASUS DRW-24B1ST/BLK/B/AS DVD/RW

So here's the problem: every time I install AMD graphics drivers, the system CONSTANTLY freezes up with the error ""Display driver stopped responding and has recovered"... if I uninstall the drivers and use Windows VGA drivers everything is perfect, but then I'm limited to 1400x1050 resolution, plus no aero graphics.

I've tried different monitors, different cables (hdmi and vga both), checked the RAM (fine), different power supply, made sure BIOS is config'd correctly, re-installed Windows 3 times, tried MANY times with different AMD legacy drivers going back to 11.8 (tried latest drivers too) ... I am at my wit's end!!

Please, someone help me. I had to save for over a year to be able to build this pc and I can't even use it the way I was hoping.

More about : build amd series work amd drivers

November 14, 2012 1:03:08 AM

Oh, forgot to mention that I also installed the Microsoft hotfix for this issue and no improvement... I basically tried all the "fixes" I found doing a google search for that particular error, all to no avail.
m
0
l
!