Sign in with
Sign up | Sign in
Your question

6950 display driver crashing

Last response: in Graphics & Displays
Share
November 14, 2012 10:04:51 PM

Hi everyone, I'm hoping I can get some advice on what is going wrong with my new computer. It's my first real build for gaming and I've tried to get good components to be able to get the most out my games but my display driver keeps crashing for some reason and I'm at a loss as to what could be causing it. I'm running a HIS 6950 with the 6970 bios flashed to it, an AMD FX 8120 cooled with a Cooler Master Hyper N520 heatsink, 8Gbs of 1600MHz RAM (8 more coming in the mail soon), an Gigabyte GA-970-A-D3 with the newest bios flashed to it, 500gb hard drive half full, and a 550 watt power supply (wondering if that's where I'm coming up short) on a fresh install of Windows 7 Ultimate 64 bit. I've installed the newest drivers,tried the catayst 12.11 beta and when it started crashing went back to the 12.10. I have overclocked the cpu slightly to 4.0GHz by changing the multiplier to 20.0 and it hasn't crashed. I left the memory and video card alone so they are running on auto settings. My temps are staying around 40c, the video card itself has gotten as hot as 64c but overall it's running very cool and still crashing even with the side panel off. Any ideas what I'm doing wrong here or if it's the psu needing to be upgraded to something more powerful? Thank you for any help I'm pulling hair out here trying to play skyrim
November 15, 2012 1:18:05 AM

First you shouldn't update bios unless it is to solve some specific known problem.
Updating the bios can certainly screw it up, and so can overclocking it.
So, you should start with all the stock settings...
You never mentioned why you would put 6970 bios onto a 6950(?)
You never listed the hardware...all of the hardware...
But you can try all this stuff: follow the directions and try it again...
Sign in as administrator (If you are not administrator you may be blocked)
Close all the applications that are being used...save and close your files...
Turn Off the antivirus and firewall, turn off the functions of windows defender.
If you have multiple security programs installed, they must be turned ALL off. Security will prevent your driver from installing...
Download the latest CCC driver package, and save it to an easy location. Make sure this is the correct driver for your card.
Delete all the current AMD video software and drivers, restart the system (the video will look screwy, don't worry)
Now load install all the newest CCC drivers and restart the system (the driver will not work (yet) as you said, but load it anyway)
left click start
left click computer
right click C drive
Left click Open
Right click Users
Left click properties
"Check" mark the box that says: Attributes: "Hidden" (there is now a check-mark in the "Hidden" box)
Click: "Apply"
Now the system will apply the hidden attributes...and this will take a while, or maybe a long while. Let this proceed, and don't interrupt it...
During this procedure, a message may inform you that you do not have administrator privilege to the file you are trying to change the attributes of. That's OK. Just click: "ignore all."
When this procedure is finished, click OK (the box will close after you click OK)
Now you will once again be looking at folders in C drive (don’t close the C drive window or you may regret it)
(once again) right click Users
(once again) left click properties
UN- check the box that says: Attributes "Hidden" (you will now take the check mark OUT, Hidden is no longer checked)
Click Apply
Now the computer will UN-apply the hidden attributes, and it may take a while, or a long while...but let it proceed, and finish, don't interrupt it.
During this procedure, a message may inform you that you are not the administrator of the file that you are trying to change the attributes of. That's OK, just click: "ignore all."
When this is completed click OK
Now close all windows and restart the computer
turn all the security back on.
At this point, the CCC should be functional. Open the CCC and test the functions
One thing is to make sure that the priority of the game is highest; there maybe other processes running that have priority over the game.
Including for instance security programs and antivirus. The latest of which have gaming modes.
If there is not a gaming mode on the security try turning it OFF. Now test it with the security turned off. Multiple mismatched security programs can cause conflicts.
“Free” security downloaded from the internet can cause lots of problems…



Another good thing is to eliminate as many unused / junk / UN-needed applications.
Try to get rid of resource hog, un needed / unnecessary applications.
turn off the screen saver
Go into the power profiles,
set standby, hibernate and sleep to OFF
leave the monitor standby ON, that's OK (maybe not, try OFF)
Set the Hard Drive standby to NEVER
Set system Performance to MAXIMUM, not "quiet mode."

Open the bios set up and make sure "cool and quiet" is OFF. (AMD)
There may be a performance setting in the bios setup you have...make sure it's cranked up to max.
in the bios, see that the allocation for video, if available, is maxed.

Now open the hardware manager profiles...
click start
click computer
click system properties
click device manager
double click on mice and other pointing devices
right click on HID compliant mouse
left click on properties
click on the power management tab
UN-check the box that says: "allow the computer to turn off this device to save power." (there is now NO check mark in this box)
click OK

Now repeat this procedure for all mice, monitors, keyboards, and ALL USB ports on the device manager list.

You must open ALL the devices one at a time, as above, and turn off the power saver, for each device.
m
0
l
November 15, 2012 1:48:45 AM

Hey,

First of all try removing all of your graphics drivers, and installing the latest ones. What is the voltage on your GPU? If the temps are okay, and the voltage is within a safe margin, then you could try to bump it up a bit to see if that gets your GPU stable. As the hd6950 was binned to be a hd6950 flashing it to a hd6970 could mean that you need more voltage to get it stable. Also note that you only have a 550watt psu, and an overclocked fx processor is rather power hungry. You could try to put it back to stock for a while and see if that helps.

Hope this helps!
m
0
l
November 22, 2012 12:57:59 AM

thanks for all the suggestions, i tried them all to no avail , wiped everything out that had amd or ati on it with driver fusion then reinstalled but it didn't help, i already only had the latest drivers because i just built the computer a couple weeks ago and did a fresh install of windows when i built it so those were the only display drivers there. i did figure it out though,heat. i have a good size cooler on the cpu and a 120mm fan on the intake of the case as well as a faster 120mm exhausting the case so i have a good negative pressure. i took the gpu apart before i posted and cleaned it thoroughly and put arctic silver on it so i thought that would be good to go,not the case,for some reason the card gets up close to 70c and then starts screwing up,gray lines on the screen or just a white screen,then i'll go to the task manager which tells me the game is not responding and i'll have to shut it down. so, i started enabling manual fan control in ccc and making the fan run at 60% while i game and it hasn't done it since. what worries me is i'm sure the card should be able to function at those temps but it won't. so at this point i guess the card is on its way out. like i said,airflow is good and the card has plenty of room to stay cool but that seems to be the problem.i'm getting a corsair 750 watt modular psu next then i'll try to do something about getting a new video card,just stuck wondering why a card this big has 1 fan on it
m
0
l
!