Sign in with
Sign up | Sign in
Your question

My new Motherboard won't recognize a keyboard

Last response: in Systems
Share
December 30, 2012 8:33:55 PM

Hello,
Just finished my first build. My motherboard is an AsRock Z77 Extreme 3. I got it to recognize a keyboard after everything as put together but I did not have Windows yet. Picked up Windows today but now it will not recognize any keyboard, ps/2or USB. Cannot get into BIOS to change legacy settings cannot load Windows. it is stuck on AsRock Post screen. I could use some help. Checked to make sure the other keyboards work already. The lights flash when the new System powers on, but thats it. Thanks in advance for the help.
December 30, 2012 8:40:35 PM

Turn off your computer.
Put the keyboard into the PS2 Port.
Turn back on.

PS2 isn't hotwire, you can't pop and play like USB, try that, then come back to us.
m
0
l
December 30, 2012 9:16:02 PM

Thank you. I tried that. No change.
m
0
l
Related resources
a b V Motherboard
December 30, 2012 9:19:18 PM

So, what's the problem now? Boot stops at the splash screen or doesn't recognize keyboard?
m
0
l
December 30, 2012 9:29:42 PM

Doesn't recognize any keyboard. We have tried 4, ps/2 and USB and we know they work on other systems
m
0
l
December 30, 2012 9:33:17 PM

When we plug the keyboard into ps/2 socket it flashes showing its getting power, but will not let us use the keyboard. Right now we have only memory, video card, GPU and CPU running so its bare minimum off of motherboard still nothing. Have also reset CMOS.
m
0
l
a b V Motherboard
December 30, 2012 9:36:41 PM

how many USB ports did you try?
m
0
l
December 30, 2012 9:40:54 PM

All 6. 4-2.0's and 2-3.0's and the PS/2 port.
m
0
l
December 30, 2012 9:42:51 PM

Tried the ones in the front and the back for the 2.0's. Then tried the 3.0's then the PS/2 port with 2 different keyboards for that.
m
0
l
a b V Motherboard
December 30, 2012 10:21:03 PM

assemble out of case. what happens?
m
0
l
December 31, 2012 7:40:21 AM

Ok did it out of case no change
m
0
l
December 31, 2012 8:46:56 AM

Disassembled entire setup, removed CMOS battery and reinserted and reassembled and seems to be working. Thanks for the input.
m
0
l
January 1, 2013 5:20:53 PM

Ok, thought it was working, now need to reset BIOS so we can install Windows but none of the usual ways are working. Any suggestions?
m
0
l
a b V Motherboard
January 1, 2013 7:51:14 PM

after you made the dvd first boot device/hard drive second and disabled the floppy ( 3rd boot device NONE ), did you hit F10 and then ENTER so it saves?


does the BIOS keep the correct date and time?

m
0
l
January 1, 2013 8:17:53 PM

Yes, and it saved correct date and time. Put in Win 7 disc to install and restarted system and optical drive starts to spin then stops, will not register keyboard again to get back into BIOS to see if there is an issue there. Even tried plugging in a USB mouse to se if there was no power to the ports on the mobo, strangely, the mouse has power even with the system not powered on. Tried to disassemble completely, pull battery from mobo and jumper CMOS again which is how we got it to reset yesterday, all to no avail. Still have to hold down power button to power off, so something is holding memory. Am getting very frustrated. No beeps through in case speaker at power on, tried to swap out SATA and cables...nothing. I am still stuck on AsRock post screen.
m
0
l
January 1, 2013 8:25:03 PM

Wondering if maybe we have received a faulty optical drive and if we could pull the optical drive from my boyfriends recent build to get This one up and running with Windows installed until we can get the drive replaced. Would a bad drive maybe cause these problems if BIOS is set to boot from it?
m
0
l
a b V Motherboard
January 1, 2013 8:41:35 PM

bad motherboard? too much going on at once.
m
0
l
January 1, 2013 8:59:45 PM

Not sure if it is the motherboard... The problem ATM is not being able to reset BIOS. Got it to reset once by jumper'ing CMOS and removing battery from mobo. That process will not work now. Any ideas on an alternate method?
m
0
l
!