Sign in with
Sign up | Sign in
Your question

HD 7770 issues

Last response: in Graphics & Displays
Share
November 15, 2012 11:42:05 AM

Hello,
I recently bought an amd hd 7770 video card as an upgrade to my 8800 gtx. i first removed all the drivers on the gtx then installed the disc drivers that came with the card. when i did i was getting all kinds of problems with catalyst can't open this and that. tried beta drivers tried reformatting and starting from scratch no results so far? im starting to think it might be my motherboard im running a nforce 590 sli with an amd athlon processor i know old school but i haven't upgraded the system since i got it. wondering if maybe its not compatible i have a 500w power supply too. since the drivers were put on the computer i can set the desktop to 1080p so i think they somewhat worked cant get amd catalyst to work and any programs that i open close within seconds. with errors attached. looking for any help let me know please!

More about : 7770 issues

November 15, 2012 11:49:58 AM

Can you try installing only the newest driver and not catalyst control center? What exactly are the errors that you are getting?
November 15, 2012 11:52:35 AM

I might be retarded with it but the cd was with catalyst and on the website seems like all the drivers come with catalyst i dont think i cant use the card without catalyst
Related resources
November 15, 2012 1:28:13 PM

Don't use the disc. Go to amd.com and download the 12.10 driver. Uninstall the drivers you currently have through control panel. Boot into safe mode and use driver sweeper to remove any amd drivers and nvidia display drivers left over. Boot into normal and install the 12.10.
November 16, 2012 1:36:16 PM

here are just the errors i get when booting more actually popped up after a few seconds but im going to try 12.10 im in safe mode now on the computer and on firefox because it crashed so many times. http://tinypic.com/r/2a7d46p/6
November 21, 2012 9:55:36 PM

jonnyspro said:
here are just the errors i get when booting more actually popped up after a few seconds but im going to try 12.10 im in safe mode now on the computer and on firefox because it crashed so many times. http://tinypic.com/r/2a7d46p/6



I finally found someone with the same problem. I have been looking for 3 weeks for a solution to this, lucky for you I found it today.
It is very simple, get rid of windows vista. I tried everything possible (other motherboard, ram, hard disk, processor, power supply, install vista over and over again)
I got windows 7 pro now (I guess any win 7 or 8 version will do) and it runs perfectly. I just can`t understand why it worked the first 6 months I had this video card with vista.
After I installed windows 7 I first did all the updates and installed the latest driver from the ati site.

This worked for my so good luck and I hope you get your pc fixed.
December 2, 2012 1:20:38 AM

Im definetly willing to give this a go. Working on gett in ng my hands on a copy of win 7 at the moment because nothing else worked
December 4, 2012 11:29:17 AM

So the windows 7 install worked right away. Still got some error about mom.exe dont know what that is but everything is working so im not too worried about it. Thanks for all the input guys!
!