NEED HELP! 660 Not being detected

Hey,
I have a huge problem, and that is that my GPU is not being detected,
is shows all signs of life, i can hear ans see the fan spinning, but when i connect the HDMI cable, nothing happens, if i try to install the drivers, it will not detect my GPU,
The Gpu has power, its not the PCIe slot, tried all 3, and the integrated intel 4000 graphics work,
Please help me, i would realy like to solve this withing tonight :)
-Me
10 answers Last reply
More about need help detected
  1. Use the DVI port. That is the default main monitor port. I am guessing that's the issue. If that doesn't work, remove intel graphics drivers and set video to pcie in the BIOS.
  2. I have, Not working, how do i remove the intel graphics drivers?
  3. just go to bios and disabled the onboard gpu
  4. Ive tried, cant seem to find where it is
  5. sorry for beeing such a noob,
  6. I Have the Z77 MSI Mpower,
  7. is this u r mobo http://www.msi.com/product/mb/Z77-MPOWER.html#/?div=Overview
    it dosent have onboard gpu
    wait a minute u got no display when u install gpu to pci slot try boot ing up u r pc with 1 ram and see if u got display on it other wise check another gpu to get display if gpu is faulty then rma it if u got no display with by placing another gpu in each pcie slot then the mobo have issue and go rma it
  8. Ive got that MOBO, it has a HDMI slot, and its using the integrated intel HD 4000. i have display, im writong on it now, in fact, my card has power, but is not beeing detected by anythind (NVIDIA driver download or Windows )
  9. Twinkletoes said:
    Ive got that MOBO, it has a HDMI slot, and its using the integrated intel HD 4000. i have display, im writong on it now, in fact, my card has power, but is not beeing detected by anythind (NVIDIA driver download or Windows )



    which os do u have 64 bit or 32 bit
    if 64 go for this http://www.nvidia.in/object/win8-win7-winvista-64bit-310.54-beta-driver-in.html

    if 32 bit then http://www.nvidia.in/object/win8-win7-winvista-32bit-310.54-beta-driver-in.html

    make sure u connected ur monitor to dvi port of graphic card not mobo hdmi to monitor
Ask a new question

Read More

Graphics Cards GPUs Graphics