Sign in with
Sign up | Sign in
Your question

Router DHCP handing out IP addresses not on the same subnet

Last response: in Networking
Share
December 22, 2011 1:10:46 PM

I've been in IT/networking for 10 plus years and this is baffling me and also have stumped the Belkin technician. I have a Belkin model F9K1102 router supplying WAN/LAN connection to three PCs and 2 laptops. Two of the PCs are hardwired with the remainder PC and laptops are wireless. I'm using the default router IP of 192.168.2.1 and my ISP is Charter Cable (if that's of significance). The router is picking up all the dynamic IP information from my ISP and internal DHCP is enabled. Here's the issue though - when I connect a PC, laptop or iTouch (wired or wireless) with obtain IP settings automatically enabled the IP address it receives an IP address on a different subnet ie, 192.168.3.x and thus won't have WAN/LAN connection. I have tried to set the router IP to 192.168.3.1 and set the scope in the .3 subnet but the IP obtained by the device is .4! This makes no sense to me at all. The router is on the latest firmware (according to Belkin) and there doesn't seem to be any other update I can find. I have also tried another Belkin router (older model: F5D8236) and it does the same thing.
I'm not sure if this is related but I upgraded my service with Charter to a 18MB connection and a D3.0 Ubee cable modem - this issue seem to have began after this upgrade but I don't see how that would have any bearing on what is happening on my LAN IP scope and Charter tech support is pretty useless. My workaround is that I've static assigned an IP for each device in the same subnet as the router but it would be nice for the DHCP to function correctly.
Any suggestions would be most appreciated.
December 22, 2011 11:00:06 PM

It sounds like you have a rogue DHCP service (Internet connection sharing?) running on one of your PCs, or a rogue wireless router hooked up wrong.
m
0
l
December 23, 2011 3:51:26 AM

Are you sure the subnet mask is 255.255.255.0 and not 255.255.0.0?

When all else fails, do a factory reset on the router (hold the reset button for 30 secs while powered ON). These consumer-grade routers are not the most robust devices, and given enough time and configuration changes, you're bound to get some goofy behavior from numerous unknown bugs. After a while it just makes sense to clear everything and start over.
m
0
l
Related resources
January 1, 2012 9:13:52 PM

PhilFrisbie said:
It sounds like you have a rogue DHCP service (Internet connection sharing?) running on one of your PCs, or a rogue wireless router hooked up wrong.


I would like to find this "rogue" wireless router somewhere! I've checked all my devices and ICS is not enabled on any of them but great suggestions - thank you for reading and responding!
m
0
l
January 1, 2012 9:15:14 PM

eibgrad said:
Are you sure the subnet mask is 255.255.255.0 and not 255.255.0.0?

When all else fails, do a factory reset on the router (hold the reset button for 30 secs while powered ON). These consumer-grade routers are not the most robust devices, and given enough time and configuration changes, you're bound to get some goofy behavior from numerous unknown bugs. After a while it just makes sense to clear everything and start over.



I have factor reset the older Belkin router several times but haven't reset the newest one - I will try that. Thank you for reading and responding.
m
0
l
January 6, 2012 1:21:55 PM

Are you certain the ubee device isn't a combo modem/router? I have one from TWC and it definitely does both which might help explain things. You can probably set it to bridge mode and that would basically turn it back into just a modem if that's how you wanted it setup. An easy way to check would be looking at the wan ip address of your belkin router and if its in the 192.168.*.* range you know the ubee is also handing out internal ips and acting as a router.
m
0
l
February 23, 2012 1:06:32 AM

Hi - log into your router and check the dhcp server range - I think you'll find it's not set to the right adress range ( i.e 192.168.0.1 to 192.168.0.254. You can typically define a range of "private" ip adresses it will serve out when it receives a dhcp request. ( the Ubee can also serve out "static" ip addresses to devices - but you have to provide their MAC address. You might also check that no other device on your network has an operating dhcp server that may be conflicting with the 192.168.2.1 dhcp server.
m
0
l
November 25, 2012 6:02:29 PM

cklunt said:
Hi - log into your router and check the dhcp server range - I think you'll find it's not set to the right adress range ( i.e 192.168.0.1 to 192.168.0.254. You can typically define a range of "private" ip adresses it will serve out when it receives a dhcp request. ( the Ubee can also serve out "static" ip addresses to devices - but you have to provide their MAC address. You might also check that no other device on your network has an operating dhcp server that may be conflicting with the 192.168.2.1 dhcp server.




I am having a similar issue. ALL my computers hooked up are 192.168.0.XXX but my daughters PC is 192.168-2.xx. When I try to change the range it takes it but then it tells me the subnet is wrong. I tried manually typing it in with the the IP but I dont know the MAC address.... I have a D-Link ( I know POS)...any ideas would be appreciated!
m
0
l
!