Solved

New build, one small problem

Hey forum, I recently built my first custom pc, and so far I am loving it! I only have one minor problem that I would like to get fixed. Let me start by stating my system specs:

Case: Thermaltake Chaser MK-1
PSU: Seasonic 650w Fully modular
MOBO: AsRock z77 extreme4
CPU: Intel i5 3570k
Ram: 8gb Gskill ripjaws at 1600mhz
GFX: XFX Radeon HD 7850 Double Dissipation 2gb
HDD: WD Caviar Blue 1tb
OS: Windows 7 Home Premium

The only problem that I have is that my front panel USB 3.0 header seems like it doesn't plug all the way into the panel on the MOBO, and only 1 of the 2 ports on my case work. Does anyone else have a problem like this?
4 answers Last reply Best Answer
More about build small problem
  1. Best answer
    Could be bad MOBO header or a bad plug from the case, my audio header was not plugged in all the way and only gave me 1 channel output, fixed it by inserting it all the way correctly. Sometimes there are little problems like this and often users just ignore it, you would likely have to RMA the MOBO or case if it is not a simple fix like getting it in all the way, which can be a hassle after a fresh build.
  2. Thanks for the reply, it just seems like something may be blocking it from going in all the way. I'm hesitant to apply even more force onto the mobo, since the extreme4 is a bit skinnier than normal ATX and doesnt use the 3 standoffs on the far right of the MOBO. Ill have to put it on the desk and try to push a bit harder.
  3. Solved the problem, one of the pins somehow became bent completely down, and i had to take the MOBO out to fix it. All up and running and both usb3 ports are functioning!
  4. Best answer selected by meyerwi.
Ask a new question

Read More

Homebuilt Systems