Graphics card not detected

hello, i recently just got my cpu.

At first when i got it, i plugged in my cpu, and installed windows/drivers, and my cpu was working.

however, my fingers got itchy, and i installed too many programs, then i decided to reformat my cpu.

After reformatting, i installed all the drivers successfully, but my graphics card driver doesn't seem to install properly. im using the onboard graphics card now. How should i proceed from here?

im using a hd7850
10 answers Last reply
More about graphics card detected
  1. oh ya, some additional info that might help...

    the graphics card fan is on

    im using a tx850w psu

    gigabyte z77-d3h mobo
  2. wouldnt the driver from the cd work? it was working about an hour ago when i first installed everything.

    it was only after the reformat did it stop working..
  3. you can't reformat your cpu.

    you mean you reformatted the hdd and reinstalled windows.

    You should uninstall the graphic card driver.
    restart the computer.
    download a fresh copy of the driver install from ati's website. (incase your version got corrupted somehow)
    install the driver.
    restart computer.
  4. Fths said:
    wouldnt the driver from the cd work? it was working about an hour ago when i first installed everything.

    it was only after the reformat did it stop working..


    ya. the drivers from the CD works. But I'd still download it from their website. cause AMD just put out new beta drivers that improves performance by a good bit.
  5. oh ya, the wires in the case were a little messy, so i rearranged it. would that be a possibility that i screwed up one of the wirings?

    i think the important thing to note is that the graphics card fan is on, so this means that the hardware is fine right? :s

    im kind of a nub at this whole cpu. thanks for the patience
  6. ya the thing is, even after installing the drivers from the cd, my gpu doesn't appear on the device manager
  7. Fths said:
    ya the thing is, even after installing the drivers from the cd, my gpu doesn't appear on the device manager


    hmm... take out the gpu and put it back in. might be a connection problem then...
  8. i really really really really hope i didn't fry my gpu or something :(
  9. Ok so I tried shutting down my CPU, pulling out the power to the mobo. When I plug it back in, the screen goes to sleep. I have to unplug the mobo before the screen comes back on.

    Oh ya, my dvi port is connected to the mobo, and I'm using the onboard gfx card now. I had this same issue earlier, but I have no idea how i foxed it
  10. Oh it finally works! The graphics card was not put in properly. Haha thanks for yor help!
Ask a new question

Read More

Graphics Cards Drivers CPUs Graphics