Sign in with
Sign up | Sign in
Your question

MSI Twin Frzr II HD 6950 2GB Stuttering

November 17, 2012 3:39:28 AM

I can't figure it out. I've tried multiple drivers, even a fresh install of my games / OS. System specs:

AMD Phenom II X6 @ 3.5GHz
8GB Kingston DDR3 @ 1600MHz
1TB HDD, 320GB HDD, 80GB HDD
PSU OCZ GameXStream 700w
MSI Twin Frzr II HD 6950 2GB

Specifically, StarCraff II lags and becomes unplayable shortly after a game starts. I can have the settings on Ultra and only get 20FPS or Low and get 22 FPS. The game quality isn't making the difference. I've read several threads where people are experiencing the same issue. To RMA my card would not fix the problem. Some didn't have enough PSU, others resolved the problem with a specific driver install. (none have worked for me)

Here are some screenshots showing details:

Main Screen: http://i.imgur.com/57NXN.jpg (820MHz, 30FPS... obviously locked)
Early Early Game (at 8X): http://i.imgur.com/Pi1U8.jpg (450MHz, 29FPS)
Early Mid-Game: http://i.imgur.com/MPoiD.jpg (500MHz, 31FPS)

Notice the FPS changes in the top right and then look at the CCC information. The shot where I tried to fast-forward the replay at the start of the game was an attempt to force a load on the GPU to make it reach the Performance State. Instead, it dropped 50MHz. It appears that the more of a load my GPU has in SCII, the less it wants to perform.

My card will perform 100% when doing benchmarks. But when I play StarCraft II, it has a mind of it's own. I've tried the Profiles settings. It doesn't help. Any ideas?
!