Sign in with
Sign up | Sign in
Your question

Bios reset help

Last response: in Systems
Share
January 1, 2013 3:58:42 PM

Hi, was hoping for some help. I recently put together a new build. I set the 1st boot to mu optical drive, restarted the computer, and my drive will read that a disc is in the bay but nothing further. Also it will not read the keyboard plugged into the ps2 and now I cannot reach the bios screen. Ive tried taking out the backup battery for a about 10 minutes, it didn't reset. I've even disassembled and reassembled the entire build all the way down to the motherboard taken out. I've also tried the jumper reset but that doesn't seem to work either. So at the moment I have a $900 paperweight, I'm at a real loss here so any help I get will be appreciated.

More about : bios reset

January 1, 2013 6:38:35 PM

It would be helpful if you mentioned the motherboard make and model

and listed the other components too
m
0
l
January 1, 2013 6:54:16 PM

Sorry. Posted this in a hurry. Motherboard is an AsRock Z77 Extreme3.
Graphics card is NVidia GEFORCE GTX 650 Ti
8 GB Ballistix DDR3memory.
Intel i5 2500k processor,
Antec Neo Eco 620W power supply
Hard drive is Toshiba 1.0 Tb
Optical drive is Asus
Apevia X-Telstar S junior type mid-tower case
m
0
l
Related resources
January 1, 2013 6:59:33 PM

My fiancé built his the same way and oversaw mine and we did everything the same with mine as we did his, but cannot seem to get away from the POST screen. Tried multiple keyboards, both USB and PS/2 all of which work on other PC's. Legacy for USB ports was default enabled, but neither type of keyboard will work.
m
0
l
January 1, 2013 7:06:19 PM

Try taking the battery out for half an hour

Computer unplugged , of course

Try a USB mouse

Do you have a speaker on the motherboard so you can hear BIOS beeps? That would also be a good idea if you dont
m
0
l
January 1, 2013 7:15:54 PM

Ok. Will try mouse. Yes there is a built in speaker on the front of the case. There has not been any beeps since we set it up to read off the optical drive for Windows install. Will try to remove battery again and will post results.
m
0
l
January 1, 2013 7:38:37 PM

It registers a USB mouse even without the power on. The battery was out of the mobo from when my boyfriend was troubleshooting this morning so it was out well over 2 hours. He also tried jumper'ing the CMOS to reset with no luck. It is still stuck on AsRock splash screen. The optical drive light comes on when you insert Win 7 disc for install but it only stays on for about 3-5 secs then shuts off. Cannot get back into BIOS. No beeps upon boot. I am at a loss for what to try next.
m
0
l
!