Sign in with
Sign up | Sign in
Your question

New build turns on, doesn't POST

Last response: in Systems
Share
January 2, 2013 8:48:43 PM

I have just put together my new build today. I have managed to get everything plugged in properly and working. When I plug into monitor it says No Signal. I have used the onboard graphics as well as my graphics card. Please help ASAP!!! I have waited a week for this build as my original mobo came DOA.

CPU: AMD FX-8320 8 core processor

Mobo: MSI 760GM-e51(FX)

RAM: 8GB Corsair ValueSelect/ 8GB AMD Performance Edition (both are 1333 mHz)

GPU: Sapphire Radeon HD 7770 OC

PSU: Diablotek 600 Watt PSDA

I currently have a Sempron-145 in the mobo as the BIOS needs to be flashed. I am using the stock cooler for the 8320 in the Sempron. Any suggestions would help.

Thank you all,

dat1kid

More about : build turns post

January 2, 2013 8:51:57 PM

Your board doesn't have onboard graphics, FX do not come with on-die graphics units. Your discrete card may be dead, also check to make sure it's completely connected.
m
0
l
January 2, 2013 8:56:37 PM

In that case should my GPU work then? Bcuz i have tried both on board and GPU on two different monitors and neither seem to work.
m
0
l
Related resources
January 2, 2013 9:14:40 PM

Does your monitor have an LED POST readout/debugger, if yes then try to post one more time and note the POST code it stops at, then consult your decoder card and see what the code means, then post it for more help.

Also does your GPU fans spin up? or no, if not, the GPU is probably dead. Another thing to try is to make sure the PCIe power connections to the GPU are fully plugged in, and make sure you have all the necessary connections, some GPU need 2x PCIe power connectors.
m
0
l
January 2, 2013 9:42:58 PM

mine only takes one, all of the fans spin up, when i go to turn it on nothing happens on screen, only the fans spin up. i have checked ALL connections.
m
0
l
January 24, 2013 10:58:35 PM

got computer working, can run metro 2033 in ultra settings at 1776x1000 with no lag! thanks for your help, the problem was with my RAM, its dual channel so when i plugged it all in it worked. I am enjoying it! thank you all
m
0
l
!