Sign in with
Sign up | Sign in
Your question

Cant access internet get local message only on wireless

Last response: in Wireless Networking
Share
January 3, 2012 4:03:52 PM

Hello, In Windows Vista I am able to connect to wireless router, but can't access internet due to Local message only. Have repaired network adapter , reset cable modemm unchecked version 6 of TCPIP network settings.
January 3, 2012 11:01:45 PM

If you are at all techy then give this a try other wise do not attempt

CAUSE
This issue occurs because of a difference in design between Windows Vista and Microsoft Windows XP Service Pack 2 (SP2). Specifically, in Windows XP SP2, the BROADCAST flag in DHCP discovery packets is set to 0 (disabled). In Windows Vista, the BROADCAST flag in DHCP discovery packets is not disabled. Therefore, some routers and some non-Microsoft DHCP servers cannot process the DHCP discovery packets.

RESOLUTION
Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.To resolve this issue, disable the DHCP BROADCAST flag in Windows Vista. To do this, follow these steps:
1. Click Start, type regedit in the Start Search box, and then click regedit in the Programs list.

If you are prompted for an administrator password or for confirmation, type your password, or click Continue.
2. Locate and then click the following registry subkey:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{GUID}
In this registry path, click the (GUID) subkey that corresponds to the network adapter that is connected to the network.
3. On the Edit menu, point to New, and then click DWORD (32-bit) Value.
4. In the New Value #1 box, type DhcpConnEnableBcastFlagToggle, and then press ENTER.
5. Right-click DhcpConnEnableBcastFlagToggle, and then click Modify.
6. In the Value data box, type 1, and then click OK.
7. Close Registry Editor.

MORE INFORMATION
If the router or the non-Microsoft DHCP server does not support the DHCP BROADCAST flag, you can set the following registry entry as follows:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{GUID}

Value name: DhcpConnForceBroadcastFlag
Value type: REG_DWORD
Value data: 0
Note A data value of 0 disables this registry entry. You can use this registry entry to prevent Windows Vista from using the DHCP BROADCAST flag. After you set this registry entry, Windows Vista never uses the DHCP BROADCAST flag
m
0
l
January 4, 2012 4:45:22 PM

brostbill said:
Hello, In Windows Vista I am able to connect to wireless router, but can't access internet due to Local message only. Have repaired network adapter , reset cable modemm unchecked version 6 of TCPIP network settings.



Darlinpchelp... Tried your suggestion last night , but with no luck. I set value to 1 and then tried as the additional information as though DHCP Broadcast flag was not supported.

In this path KEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{GUID}

Do I need to delete any existing DHCPEnableBcastFlag files, ext...
m
0
l
January 4, 2012 7:24:22 PM

do a registry scan use http://www.filehippo.com/download_ccleaner/download/ac2... Have you attempted to check if there is an update for the driver or delete and re install driver

If still persists when did this actually occur were you working, playing game surfing or what just so I can have a better idea of what may have cause this to occur
m
0
l
!