Sign in with
Sign up | Sign in
Your question

7950 not getting good fps

Last response: in Graphics & Displays
Share
November 19, 2012 4:21:08 AM

I bought a 7950 this one right here http://www.newegg.com/Product/Product.aspx?Item=N82E168... it came with sleeping dogs and i tried playing it on high settings and i am getting horrible fps like less than 30 and on ultra its like 10.

Also tried SC2 and its like 35 on ultra and on LoL its also 35 on max settings.

I have seen videos on youtube of this card maxing all of these games with good fps i have downloaded the newest drivers i don't know what the problem is can some help me?

Specs: CPU:i5 3570k PSU:rosewill 630w 80+ bronze 8gb ram 1tb HDD

More about : 7950 good fps

a c 169 U Graphics card
November 19, 2012 6:05:07 AM

What resolution do you play on ?
Maybe your card doesn't switch to 3D clocks when you switch to games.Download GPU-Z>Sensor tab and check if your card's clocks change when you play a game or not
m
0
l
November 19, 2012 6:08:29 AM

Maziar said:
What resolution do you play on ?
Maybe your card doesn't switch to 3D clocks when you switch to games.Download GPU-Z>Sensor tab and check if your card's clocks change when you play a game or not



1440x900
m
0
l
Related resources
a b U Graphics card
November 19, 2012 6:11:11 AM

I get 60 +/- with Phemon II x4 @ 3.4 all maxed except aa at medium, and 6950 2GB.

AA is always the most intensive, and personallt the least noticable. YMMV

Edit: video card
m
0
l
November 19, 2012 6:29:10 AM

abbadon_34 said:
I get 60 +/- with Phemon II x4 @ 3.4 all maxed except aa at medium, and 6850 2GB.

AA is always the most intensive, and personallt the least noticable. YMMV



What games and what resolution?
m
0
l
a c 106 U Graphics card
November 19, 2012 6:37:44 AM

thats definitely abnormal, especially at that resolution. what I would recommend is to use gpu-z and do a test gpu stress run to see if your gpu changes from idle pci-e 1.0 x4 to whatever your land speed is(should be pci-e 3.0 at x16 under stress) after that i would monitor the clock rates and if neither work, I would instal drivers from scratch by manually uninstalling the AMD drivers and registry keys(there is a guide)
m
0
l
a b U Graphics card
November 19, 2012 7:08:34 AM

lemongrassgogolo said:
What games and what resolution?


Sorry, typo 6950 2GB, 60 +/- with Phemon II x4 @ 3.4 all maxed except aa at medium. Sleeping
dogs & black ops 2 (single player)

Can't quite remember the other games, but all try to play at max settings expect AA med. XOMC was 60 max, but no surprise. Bordlands 2 jumped around a bit but with low physics got 60 except for the notorious water psysic.

Hope this helps and does't confuse
m
0
l
a b U Graphics card
November 19, 2012 7:46:18 AM

btw, you do have most recent Sleepging Dogs update installed right? 1.5 or 1.7 i think?

P.S. I only time (reflected in your benchmark) that's you'll really see problems is in that house with the sum painting, 40% of games is cinematic, 50% is running aroud the streets, 10% is actually intensive. I ended up setting mine a bit higher than normal cause the high graphics parts are quite impressive, and becuase that 10% is so a far and few between, and can change it on fly, I didn't notice
m
0
l
!