Sign in with
Sign up | Sign in
Your question

Installed new SATA DVD drive, now Win7 won't boot

January 4, 2013 5:41:58 PM

Hello!

I recently built a new computer and installed Windows 7 on a Raid 5 array. I had some trouble setting up the array at first as instructions from ASRock are a bit messy IMO, and also I did not have an optical drive (didn't realize that the MB wouldn't have headers for my old IDE drive). I did get everything working, with my array on SATA ports 1-2-3, and the Caviar Green plugged in port 5. Installed Windows, drivers, apps and games (tens of GBs of downloads...)

Yesterday I received my SATA DVD writer and thought I would just plug it in SATA port 4 (last remaining port) and be ready to go. Here comes the trouble.

Did this, and Windows won't boot. It just gets to a black screen with flashing cursor and stays there forever. Everything is recognized properly in BIOS, and I can boot off the Win7 DVD just fine.

I figured I would do that and tell it to "repair Windows" or whatever. It doesn't see my Windows installation at all: trying to load RAID drivers off a USB device or DVD (tried both), Windows still isn't recognized.

Now for the tricky part. When I browse to choose drivers, I initially see my empty Caviar, and the USB drive that holds the drivers. I load the drivers and Windows still doesn't appear. I go back to browsing for RAID drivers, and now my array shows up! I can browse the files from the Windows install, all my drives and everything show up, but the install disc still tells me that I don't have Windows installed, so obviously I can't repair it. I did use the Windows disc to look for errors, but that returned nothing.

I also tried unplugging anything unnecessary, plugging everything like it was before the DVD drive arrived, plugging drives in different SATA ports... Nothing helps.

In the BIOS the SATA controller is set to RAID. I'm afraid it's trying to see a raid composed of all 4-5 drives together? The BIOS calls whatever drive is in port 4 "RAID: 'name of drive'". What? Any drive in port 5 shows up as "SATA: 'name of drive'". If I boot into the RAID controller everything looks fine though. ASRock says to "install ODD drivers in SATA port 5": I tried plugging the drive there, but am I supposed to get drivers for it? But even then, if I go back to my initial configuration (without the DVD drive) Windows still won't boot.

Could bootsect be broken somehow? How do I repair it? I could just format, but my Windows was a clean install and it took days to install all my programs and games, so that really would be a pain. This has to be recoverable, since until plugging in the DVD drive everything worked perfectly.

I've run out of options... Please help?

ASRock 970 Extreme 3
AMD FX-6100
Patriot Viper Extreme 2x4GB DD3-1866
3xSeagate 320GB SATAII in Raid 5 (Win7)
WD Caviar Green 1.5TB SATAII (empty for now)
LG DVD Writer SATA
Antec Truepower 750W

I also found another thread that looks similar, and maybe this answer would be the solution, but I don't understand how to do that.
!