Sign in with
Sign up | Sign in
Your question

SAPPHIRE Radeon HD 7850 Problems

Last response: in Graphics & Displays
Share
November 21, 2012 3:09:04 AM

Hi this is my first build.

Intel Core i5-3570K Ivy Bridge
SAPPHIRE Radeon HD 7850 (Factory OC)
GIGABYTE GA-Z77X-UD5H
G.SKILL Ripjaws Series 8GB
Western Digital WD Black WD1002FAEX 1TB
Antec EarthWatts EA-650 GREEN 650W
Rosewill CHALLENGER

To get to the point, I'm watching Netflix. It was all fine before when it was just 20min episodes of Family Guy. Then I watched a 2 hour long movie and all of a sudden after an hour or so, my screen just when black and white stripes running vertically (kinda like Foot Locker). The sound went off as well so I couldn't tell if movie was running still or not. So I pressed the reset button on my computer and went back to the movie. Sure enough, 30 minutes later, the screen did the same thing. This time however, sound still worked so I could test if the keyboard and mouse worked or not and they didn't (I tested by seeing if I could close window or not by alt+f4 but I could not, sound proved movie was still playing).

I tell my friend who's a pretty experienced computer guy and I invite him on Logmein and he does his magic. He said something about the card's power save mode or something like that and that the card thought I was inactive and so went to sleep. That was his guess. So he turned off the power save I believe and I thought everything was solved.

Today I watched another movie to test out if it's fixed or not. This time, the screen went completely black. Sound was still worked and keyboard and mouse yet again fails to work.

To my little knowledge I thought this 200$ piece of hardware was a decent graphics card, but hey what do I know. My other guess was the Motherboard has a problem but the on-board screen doesn't display an error code.

I have come to you guys in desperation.
a c 1401 U Graphics card
November 21, 2012 11:54:27 AM

It might be that not only the GPU was sleeping but the system it self. Go into power option in Control Panel and edit sleep settings.
m
0
l
!