Sign in with
Sign up | Sign in
Your question
Closed

AMD Vision Control Center won't open

Last response: in Graphics & Displays
Share
November 21, 2012 10:47:01 AM

Hello,

Since a couple of days I can't open my AMD Vision Control Center, and other AMD components & programs.

I don't really know why it's not working, I just can't open it, not on the Desktop and not in it's normal Folder.

ASUS K53T
OS: Windows 7,
RADEON HD6720G2
AMD VISION A6

I hope to get some help soon

January 27, 2013 8:50:29 PM

Hi,

I had the exact same issue. It's almost certainly because you've updated AMD 'WITHOUT UNINSTALLING' the previous drivers.

To fix;
1. Get hold of a Driver cleaner ..I used "Driver Sweeper".
2. Uninstall ALL the AMD stuff. Easiest way is to double click one of the updates you've already used. It will then give you the option to Install or Uninstall. Uninstall the lot!!
3. REBOOT.
4. Start Driver Sweeper. Check the box alongside AMD (No others!).
5. Run the Sweeper.
6. REBOOT.
7. Now install the LATEST AMD update.
8. REBOOT. You should now be able to open the Vision Centre, and everything will be Hunky Dory!!

Pete :) 
April 9, 2013 11:56:31 PM

The problem, as it has been for many people, is a Microsoft "improvement" to Windows 7's graphics to make it more Windows-8-like and support IE10 - but it also breaks ATI's display drivers. This is the culprit: update KB2670838. I have an ATI Radeon HD2600XT and this has been vexing me for months. It has also been making Windows Calculator unusable - which is where I found the solution (http://answers.microsoft.com/en-us/windows/forum/window...). Shame on Microsoft for releasing a 'patch' which breaks so many people's display drivers - and not fixing it!

As soon as I uninstalled this patch (via Control Panel / Programs and Features / Show Updates) and rebooted, CCC began working just fine - and Calculator was back to normal too.
Related resources
April 11, 2013 3:03:03 AM

Hmmm, I don't have that update, Auriam (though I will certainly look out for it!) so this must be a separate issue. Readers may like to try both solutions.
P :) 
August 29, 2013 3:15:40 PM

PeteX said:
Hi,

I had the exact same issue. It's almost certainly because you've updated AMD 'WITHOUT UNINSTALLING' the previous drivers.

To fix;
1. Get hold of a Driver cleaner ..I used "Driver Sweeper".
2. Uninstall ALL the AMD stuff. Easiest way is to double click one of the updates you've already used. It will then give you the option to Install or Uninstall. Uninstall the lot!!
3. REBOOT.
4. Start Driver Sweeper. Check the box alongside AMD (No others!).
5. Run the Sweeper.
6. REBOOT.
7. Now install the LATEST AMD update.
8. REBOOT. You should now be able to open the Vision Centre, and everything will be Hunky Dory!!

Pete :) 


^^^This worked for me :)  ty
!