Sign in with
Sign up | Sign in
Your question

New build boot issues

Last response: in Systems
Share
January 5, 2013 1:57:17 AM

i am having some issues with my new build here are my components
sabertooth x79
i7-3930k
gtx680
corsair vengeance 4x8
corsair ax1200 psu

when i try to test boot (out of case) the mobo led is green but nothing powers on including the fans on the mobo no beeps come from the speaker nothing but a click coming from the psu. i have reseated all power cables ram and vga twice and tried and had the same results. could it be a bad psu? i am grateful for any advice this is my first build and this is greatly bothering me

More about : build boot issues

January 5, 2013 2:20:24 AM

Sounds like the PSU is at fault, or atleast a likely suspect.
Try removing the RAM and attempting to start it again, the mobo should beep at you saying there's no RAM. If it doesnt, then either the Mobo or PSU is at fault.

To test the PSU, easiest thing to do is get another one thats known to work and replace it. If you get the same result, its not the PSU's fault.

If the motherboard is at fault, there isn't much you can do except to just RMA it and get another.
m
0
l
!