Sign in with
Sign up | Sign in
Your question

Debugging printer driver

Last response: in Windows XP
Share
Anonymous
a b \ Driver
February 21, 2005 7:18:52 PM

Archived from groups: microsoft.public.windowsxp.device_driver.dev (More info?)

Hi,
I am trying to setup the WinDbg debugger to debug the printer driver. I
followed the steps below-
1. Open MSPaint application.
2. In WinDbg, Select [Attach to process] menu option. Select MSPaint
process.
3. Set the symbol path to C:\Windows\Symbols(where I installed the symbols)
4. Set the source path.
5. Set the image file path.(where my driver is kept).

After doing the steps above when I try to set a breakpoint in the code it
gives an error message saying "code not found, breakpoint not set". The
following errors are also shown in the command window of WinDbg-
.....................*** ERROR: Symbol file could not be found. Defaulted to
export symbols for C:\WINDOWS\System32\ntdll.dll -

*** ERROR: Symbol file could not be found. Defaulted to export symbols for
C:\WINDOWS\system32\ole32.dll -

*** ERROR: Symbol file could not be found. Defaulted to export symbols for
C:\WINDOWS\system32\SHLWAPI.dll -

*** ERROR: Symbol file could not be found. Defaulted to export symbols for
C:\WINDOWS\WinSxS\x86_Microsoft.Windows.GdiPlus_6595b64144ccf1df_1.0.2600.13
60_x-ww_24a2ed47\gdiplus.dll -

*** ERROR: Symbol file could not be found. Defaulted to export symbols for
C:\WINDOWS\WinSxS\x86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0
..2600.1612_x-ww_7c379b08\COMCTL32.dll -

*** ERROR: Symbol file could not be found. Defaulted to export symbols for
C:\WINDOWS\system32\USER32.dll -

*** ERROR: Symbol file could not be found. Defaulted to export symbols for
C:\WINDOWS\system32\kernel32.dll -

*** ERROR: Symbol file could not be found. Defaulted to export symbols for
C:\WINDOWS\system32\RPCRT4.dll -

*** ERROR: Symbol file could not be found. Defaulted to export symbols for
C:\WINDOWS\System32\CLBCATQ.DLL -

*** ERROR: Symbol file could not be found. Defaulted to export symbols for
C:\WINDOWS\system32\SHELL32.dll -

*** ERROR: Symbol file could not be found. Defaulted to export symbols for
C:\WINDOWS\system32\GDI32.dll -


My system configuration is -
OS - Windows - XP service pack 1
Debugger- WinDbg version 6.4.7.2
Symbol - Symbols for Windows XP sp1

If anybody have any idea what is wrong and why I am getting above errors,
please let me know.

Thanks,
Nitin
Anonymous
a b \ Driver
February 22, 2005 4:16:05 AM

Archived from groups: microsoft.public.windowsxp.device_driver.dev (More info?)

Time to hire an expert to help.
This thing isn't easy to explain over the net. I find that Microsoft
document has some slight problems too. I am able to debug ISAPI.dll, printer
Dll, and kernel mode. The debugger is working fine. You should bug
Microsoft guys because they seemed to think too high of themselves, they
lacked the verification of their samples and documentation.

Dr. Tulip


"Nitin" <nitinp@noida.hcltech.com> wrote in message
news:o arCaNAGFHA.2692@TK2MSFTNGP10.phx.gbl...
: Hi,
: I am trying to setup the WinDbg debugger to debug the printer driver. I
: followed the steps below-
: 1. Open MSPaint application.
: 2. In WinDbg, Select [Attach to process] menu option. Select MSPaint
: process.
: 3. Set the symbol path to C:\Windows\Symbols(where I installed the symbols)
: 4. Set the source path.
: 5. Set the image file path.(where my driver is kept).
:
: After doing the steps above when I try to set a breakpoint in the code it
: gives an error message saying "code not found, breakpoint not set". The
: following errors are also shown in the command window of WinDbg-
: ....................*** ERROR: Symbol file could not be found. Defaulted to
: export symbols for C:\WINDOWS\System32\ntdll.dll -
:
: *** ERROR: Symbol file could not be found. Defaulted to export symbols for
: C:\WINDOWS\system32\ole32.dll -
:
: *** ERROR: Symbol file could not be found. Defaulted to export symbols for
: C:\WINDOWS\system32\SHLWAPI.dll -
:
: *** ERROR: Symbol file could not be found. Defaulted to export symbols for
:
C:\WINDOWS\WinSxS\x86_Microsoft.Windows.GdiPlus_6595b64144ccf1df_1.0.2600.13
: 60_x-ww_24a2ed47\gdiplus.dll -
:
: *** ERROR: Symbol file could not be found. Defaulted to export symbols for
:
C:\WINDOWS\WinSxS\x86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0
: .2600.1612_x-ww_7c379b08\COMCTL32.dll -
:
: *** ERROR: Symbol file could not be found. Defaulted to export symbols for
: C:\WINDOWS\system32\USER32.dll -
:
: *** ERROR: Symbol file could not be found. Defaulted to export symbols for
: C:\WINDOWS\system32\kernel32.dll -
:
: *** ERROR: Symbol file could not be found. Defaulted to export symbols for
: C:\WINDOWS\system32\RPCRT4.dll -
:
: *** ERROR: Symbol file could not be found. Defaulted to export symbols for
: C:\WINDOWS\System32\CLBCATQ.DLL -
:
: *** ERROR: Symbol file could not be found. Defaulted to export symbols for
: C:\WINDOWS\system32\SHELL32.dll -
:
: *** ERROR: Symbol file could not be found. Defaulted to export symbols for
: C:\WINDOWS\system32\GDI32.dll -
:
:
: My system configuration is -
: OS - Windows - XP service pack 1
: Debugger- WinDbg version 6.4.7.2
: Symbol - Symbols for Windows XP sp1
:
: If anybody have any idea what is wrong and why I am getting above errors,
: please let me know.
:
: Thanks,
: Nitin
:
:
:
!