Sign in with
Sign up | Sign in
Your question

5970 second GPU undetected by everything

Last response: in Graphics & Displays
Share
November 23, 2012 10:55:55 PM

Hi guys I just picked up a 5970 from eBay for $80 the guy I bought it from believes it works fine (although he was quite eger to get rid of it selling it for 80 bucks). So I get it and set it up and run gpuz because i've herd of 5970 not showing a second GPU and loandbehold crossfires disabled so after about 4 hours of forum surfing I tried running atiflash just to get a read and see if the problem is windows related and it turns out that atiflash doesn't pick up the second (or possibly master) core so I've narrowed it down to being a bios/hardware issue and not windows or software I'm thinking the best way to solve this would be to try the 1+8 pin trick see if that's the problem but before I do that I'd like to get another opinion on the matter thanks in advance

More about : 5970 gpu undetected

November 24, 2012 7:35:13 PM

Yeah there are any number of things that it could be but I would assume you got a lemon if he unloaded it for $80. No one sells a dual-core GPU for that little unless it isn't working right.
m
0
l
November 25, 2012 1:22:41 AM

Its was a 2 day auction so I could have got lucky but I do agree these obviously something wrong with it so my question is without RMAing or sending it back to the guy I bought it from can I fix it at the moment the single gpu works great I've been playing games on it just fine I even did a fur mark to see if it was stable and its fine. I also flashed a newer bios to the one core that dose show in atiflash and that works fine. I just cant understand how the second Gpu completely disappeared there should be some trace of it somewhere shouldn't there
m
0
l
Related resources
November 25, 2012 1:27:14 AM

Do you have the proper drivers? You need the Crossfire profiles off of the websites as well too.
m
0
l
November 25, 2012 8:12:22 AM

yep got all that catalyst 12.10 but there's no option for the crossfire profiles because It doesn't detect the second gpu
m
0
l
November 25, 2012 8:39:40 AM

Replace your original gpu with that gpu and see if it boots/works
m
0
l
November 25, 2012 8:58:00 PM

Quote:
Replace your original gpu with that gpu and see if it boots/works
could you please explain how to do this
m
0
l
November 25, 2012 9:29:51 PM

Open your case, remove your original 5970 and replace it with your new gpu. This way you can test the new card to make sure it works.
m
0
l
November 25, 2012 9:33:20 PM

the 5970 is the upgrade i originally had 2 260gtx in sli and yes I have removed the drivers and reset the cmos and yes I have tried the card in the other pci-e slot
m
0
l
November 25, 2012 10:18:45 PM

Oh oops, I didn't realize it was a multi gpu card. I was thinking you had two separate cards and trying to crossfire them. Does your motherboard support pcie 2.1?
m
0
l
November 26, 2012 12:07:57 AM

Quote:
Oh oops, I didn't realize it was a multi gpu card. I was thinking you had two separate cards and trying to crossfire them. Does your motherboard support pcie 2.1?


PCIe 3.0 ASROCK Extreme 3 Gen 3
m
0
l
November 26, 2012 12:22:46 AM

Do you have the 8 pin and 6 pin power connected? If you do, are they on the same rail (same cable but using a splitter)?
m
0
l
November 26, 2012 2:28:51 AM

yes but I and i tried using a molex to 6pin aswell just to see if it was the railing but I don't think this is the issue scenes i was running 2 GTX 260
m
0
l
December 10, 2012 12:01:04 PM

OK so kind of a bump but i tried the 1+8 pin trick and now the bios of gpu 1 has been erased and when i true to re right I get

Flash type : unknown SPI
followed by write fail and error 0FL01

I also tried 8+3 pin method but no luck but it dose show in windows but I'm not able to use it
m
0
l
December 10, 2012 3:24:06 PM

What power supply are you running?
m
0
l
December 10, 2012 10:11:58 PM

antec 650w it was able to run 2x 260gtx so I don't think thats a problem
m
0
l
December 10, 2012 10:36:17 PM

You should be fine with that yes.

Did you make sure to download the proper drivers for the crossfire setup?
m
0
l
December 11, 2012 12:26:38 AM

For those who seem to be confused, the OP refers to their dual GPU as GPU 1 and 2, leading readers to believe they mean a crossfire setup rather than a dual GPU card.

If you aren't able to reflash the BIOS on the 5970, you might have to chalk it up as a loss. It might work with the right trick, but at this point it's well beyond my knowledge.
m
0
l
December 11, 2012 3:20:16 AM

Ok sorry guys but im kind of high jakinbg this thread but my currnet problem is

I bridged pins 1+8 and it wiped and corrupted the bios for the 1st gpu on the card the one that origianly worked now I cant flash to it whenever i try to flash to it I get

C:\atiflash -f -p 0 ati.rom
Old Device ID: 689C
New Device ID: 689C

Old Product name:
new Product name: Hemlock Master blah blah blah

Old Bios version:
New Bios version: 012.020.000.028.037492

Flash type: Unknown SPI

Write fail
0/20000h bytes programmed

ERROR 0FL01 : press 1 to continue


so l've been looking in to ponyprog or something similar to see if i can make it flash it regardless of whatever errors atiflash is picking up
m
0
l
December 11, 2012 6:07:58 AM

A couple of things that you can try...

Are you using a USB 2.0 flash drive? If so, make sure it is in a USB 2.0 slot...I know it sounds silly, but I had the same problem when I tried to reflash the bios on my cards. Once I booted from the USB using a 2.0 slot, everything worked fine.

Also, since your other card works fine, make sure it is completely removed prior to flashing the bios.

Now this part I'm not sure about...I don't really have much of a clue on how multi-gpu based cards work, but does it have an individual bios for each gpu on the card? If it does (again I must stress that I don't know), try using this command to flash both gpus...
atiflash -pa biosname.rom
m
0
l
December 11, 2012 9:57:33 AM

yes Im sure its a 2.0 usb but ill try burning a CD and yes the card has 2 separate bios chips

oh and by the way as stated above I only have one card in my computer but is a 5970 which has 2 gpus on the one card.

I'm using the onboard graphics as a secondary
m
0
l
December 11, 2012 10:13:06 AM

For some reason I was thinking that you were going to try to quadfire the cards, disregard pulling the other card.

Since it has 2 seperate bios chips, try doing the command
atiflash -pa biosname.rom or atiflash -f -pa biosname.rom

Also you could try writing the bios for the second card by doing this command...
atiflash -f -p 1 biosname.rom

m
0
l
!