Sign in with
Sign up | Sign in
Your question

After switching to Nvidia from ATI blurrier text, and display.

Tags:
  • Graphics Cards
  • ATI
  • Nvidia
  • Graphics
Last response: in Graphics & Displays
Share
November 24, 2012 11:59:46 PM

I been using ati 5750 HD up until today. Got Nvidia 660 ti and updated it with latest driver. Afterwards I been trying to find info why my screen is darker and text is blurry. On my old ATI screen was crystal clear both on desktop and gaming, now I keep trying to figure out what's causing this blurry screen. Resolution is same at max 1980...

Anyone experiensed similar issue or got possible solution?

More about : switching nvidia ati blurrier text display

November 25, 2012 12:12:41 AM

Probably the new card is pushing a higher frequency than the screen can handle. Go to screen properties and see where it's set. If above 60Hz, set it back to 60 and see how that goes.

You'll find it under Appearance and Personalisation/Display/Screen Resolution/Advanced settings.


"The best display settings for an LCD monitor
If you have an LCD monitor, check your screen resolution. This helps to determine the clarity of on-screen images. It's a good practice to set an LCD monitor to its native resolution—the resolution a monitor was designed to display based on its size. To see your monitor's native resolution, check the display settings in Control Panel.

Click to open Screen Resolution.

Click the drop-down list next to Resolution. Check for the resolution marked (recommended). This is your LCD monitor's native resolution—usually the highest resolution your monitor can support.

The monitor's manufacturer or reseller should also be able to tell you the native resolution for your LCD monitor. (CRT monitors don't have a native resolution.)

Screen Resolution in Control Panel shows the recommended resolution for your monitor."
m
0
l
a c 91 U Graphics card
a b Î Nvidia
November 25, 2012 12:18:48 AM

Did the monitor settings get reset when everything else set to defaults?

That's one of the things I'd check. Also, double check the cable connections.
m
0
l
a c 217 U Graphics card
a c 84 Î Nvidia
November 25, 2012 12:27:33 AM

If you are using HDMI, you may need to look for scaling settings. HDMI defaults to have over scanning or under scanning. I forget, but HDMI always causes this. Also, using too high a refresh rate that the cable can't handle will cause blurriness too.
m
0
l
!