3rd monitor problems

I had all three monitors working last night. Woke up to find that only 2 monitors would display anything! The third is not in a displayport as a hdmi to display port converter is TO DAMN HIGH. So it is in VGA(Monitor side) to DVI-I(Graphics Card side).

Now whenever my 3rd monitor is even just plugged in, the other 2 monitors shut off, and cant do squat, until the third monitor is unplugged. Whenever I press the menu on my third monitor (Samsung) i get a Test Good message top left, sometimes it switches between analog and digital. The menu on the monitor itself is not working fully I think.

(Running a GTX 660TI)
Motherboard: Pegatron Corporation 2ac2
5 answers Last reply
More about monitor problems
  1. Both these ways work for me before.. I would unplug and replug it back in... or better works is do the cntrl alt delete combo, then cancel it.. this method always turns mine back on..
  2. No, didn't work, but thanks for trying to help :)
  3. Are you running Windows? If so right click your desktop and click 'Screen resolution'. Do all the displays show up? You should have 3 displays show up
  4. agreed with the windows suggestion. also, if you are using a NVIDIA card, check the NVIDIA control panel and make sure that all monitors are activated.
  5. Simo606 said:
    Are you running Windows? If so right click your desktop and click 'Screen resolution'. Do all the displays show up? You should have 3 displays show up

    If i connect my third monitor all the monitors go blank, so i cant even see if it does, but i hovered my mouse over the detect button in screen res as i plugged it in, monitors went blank, I clicked detect, and then unplugged the monitor to see that it did not know that their was a third monitor plugged in.
Ask a new question

Read More

Graphics Cards Monitors Graphics Displays